[SOLUCIONADO] Sustitución de membrana en un ZX spectrum 16k

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Antón_
rst 0
Mensajes: 7
Registrado: Vie Jul 23, 2010 2:52 pm

[SOLUCIONADO] Sustitución de membrana en un ZX spectrum 16k

Mensaje por Antón_ » Vie Jul 23, 2010 6:05 pm

Buenas a todos. Tengo un pequeño problema con un ZX Spectrum recuperado de un antiguo compañero de trabajo. Despues de mucho tiempo con él guardado, por fin me he hecho con un transformador de esos multivoltaje y con selector de polaridad y he podido encenderlo.
Imagen

Despues de muchas vueltas con el sintonizador de la tele, he conseguido que muestre la pantalla de bienvenida (esa con el simbolo de (C)). Aquí una imagen de su "resurrección".
Imagen

El caso es que no consigo pasar de ahí. He probado a dejar pulsada una tecla para que diera el pitido de repetición de tecla, pero nada de nada, se queda así la pantalla.
Imagen

He estado revisando información por la red y he visto que podría ser un problema de las membranas del teclado. He procedido a abrirlo para ver el estado de las fajas de conexión. Y esto es lo que me he encontrado:
Imagen

En efecto, por dentro parece estar todo bien. Fijandome más en detenimiento en las fajas, aunque las dos capas de plástico que las protejen están un poco separadas entre si, en las pistas de metal no se aprecian roturas que hagan que no funcione el teclado.
Imagen

Y por dentro todo parece muy limpio y no hay ningún condensador hinchado ni ninguna muestra de oxidación por ninguna parte. Solo estos bancos completamente vacíos, pero supongo que será normal.
Imagen

¿Alguien puede arrojarme un poco de luz sobre este tema? ¿Puede ser algún problema con el adaptador de corriente, que no le de lo necesario para funcionar al 100%?

Un saludo a todos.
Última edición por Antón_ el Lun Ago 09, 2010 5:11 pm, editado 2 veces en total.

Avatar de Usuario
JULIO
Freddy Hardest
Mensajes: 588
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum 48k arranca pero no hace más

Mensaje por JULIO » Vie Jul 23, 2010 7:04 pm

Hola, he cambiado alguna vez un condensador y aun secos
nunca los he visto abombados en una placa de spectrum.
No es el caso.
Tienes una calidad de imagen excelente :D
en las fotos se aprecia que la membrana está mal,
la mejor manera de comprobar es con polimetro,
lo pones a resistencia y debes de obtener 0 ohmn
en las zonas de conexion la tienes agrietada.
si no hay continuidad cambio de membrana.
Nunca he podido reparar una membrana con pintura de plata.
saludos
Julio.
[editado] olvidaba una cosilla, esta placa solo tiene 16 kb.

Antón_
rst 0
Mensajes: 7
Registrado: Vie Jul 23, 2010 2:52 pm

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por Antón_ » Vie Jul 23, 2010 7:24 pm

Gracias Julio por tu aclaración. Procedo a cambiar el nombre del hilo sustituyendo los 48k por 16. El compañero que me lo dio me habia dicho que era de 48, pero con el tiempo que ha pasado, seguro que ni se acordaba.

En cuanto pueda, veo lo de las continuidades y comento.

He estado buscando por la red un sitio donde vendan las membranas a un precio razonable pero no he encontrado ninguna barata o ninguna página que me resulte fiable para comprar el repuesto. ¿Me aconsejais alguna?

Un saludo.

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por mcleod_ideafix » Vie Jul 23, 2010 7:37 pm

Antón_ escribió:¿Me aconsejais alguna?

RWAP o Sintech, así que se me vengan a la memoria. En España las puedes encontrar en http://www.zxspares.com
Web: ZX Projects | Twitter: @zxprojects

Avatar de Usuario
JULIO
Freddy Hardest
Mensajes: 588
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por JULIO » Vie Jul 23, 2010 8:03 pm

Y siguiendo el hilo de las membranas, ¿es cierto que se venden unas de origen polaco que son malas de "la muerte"?
Yo sólo he comprado a un vendedor alicantino y a otro alemán.

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por mcleod_ideafix » Vie Jul 23, 2010 8:42 pm

JULIO escribió:Y siguiendo el hilo de las membranas, ¿es cierto que se venden unas de origen polaco que son malas de "la muerte"?
Yo sólo he comprado a un vendedor alicantino y a otro alemán.


Mmmmm... yo compré una vez una membrana de Plus a un vendedor polaco por eBay. Eran más baratas que las que vendían en UK. Al recibirlas, vi que no eran la misma cosa que las que venden en UK, si bien también es cierto que las vi bastante mejores que las originales de Sinclair (supongo que cualquier cosa es mejor que las originales).

Mayormente, lo que vi era que el borde del plástico de la membrana tenía muchas rebabas, como si estuviera mal cortada. Una leyenda, en polaco, o qué sé yo, indicaba "SPEKTRUM". Por lo demás, no me pareció malota.

Me costó lo suyo, eso sí, que funcionaran bien todas las teclas cuando monté la membrana en el Plus, aunque visto lo visto en posteriores ocasiones con membranas de otros fabricantes, diría que no resultaron TAN malas.
Web: ZX Projects | Twitter: @zxprojects

Avatar de Usuario
JULIO
Freddy Hardest
Mensajes: 588
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por JULIO » Vie Jul 23, 2010 8:53 pm

¿Que no funcionen bien puede deberse a que la zona de contacto
está descentrada en la parte externa?
Y esto se aprecia sin duda en las fotos que hay en algunos sitios de venta de membranas. :lol:

saludos
Julio.

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por mcleod_ideafix » Vie Jul 23, 2010 9:04 pm

JULIO escribió:¿Que no funcionen bien puede deberse a que la zona de contacto
está descentrada en la parte externa?


Sí, es por eso, o bien las pistas de esa zona son demasiado cortas, o bien no caen justo en la zona entre los dos tornillos de la mordaza y tienes que poner las cintas en una postura más adecuada antes de trabarlas con la mordaza de plástico y los tornillos en el Plus.
Web: ZX Projects | Twitter: @zxprojects

Antón_
rst 0
Mensajes: 7
Registrado: Vie Jul 23, 2010 2:52 pm

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por Antón_ » Lun Jul 26, 2010 7:18 pm

Buenas, he querido comprobar el estado de las membranas, pero me ha surgido un problema: no soy capaz de entender cómo está conectado a la placa y como se abre el teclado.

He estado buscando algo de info en la red y en este foro, pero no ecuentro por ningún lado el proceso para desmontarlo. Los problemas que me encuentro son dos:

1- No se como se separan las dos fajas de la placa. Creo entender que la cobertura de plastico de una vuelta dentro de la pieza negra que conecta, y luego se vuelve a pegar sobre si misma. ¿Si simplemente lo despego y tiro hacia arriba, saldrá sin problemas?

2- No veo como se separa el cobertor de las gomas para poder acceder tanto a las propias gomas como a la membrana. ¿Tiene algún tipo de enganche o está pegado? ¿Cómo haceis para separalo vosotros?

Espero que me podais indicar como solucionar estas dudas o decirme donde puedo ver un desmontaje en foto o video para poder seguirlo.

Un saludo.

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por mcleod_ideafix » Mar Jul 27, 2010 1:10 am

- Quita los tornillos del Spectrum y ponlo en la mesa en su posición normal.

- Levanta la parte superior de la carcasa con cuidado. Verás las dos fajas del teclado que se enchufan en la placa.

- Para quitar una de las fajas, simplemente agárrala con los dedos índice y pulgar de ambas manos (haciendo pinza con ellos), a ambos lados de la faja, y lo más cerca posible del conector de teclado de la placa. Normalmente en esa zona de la faja tienen como un refuerzo de plástico precisamente para que sea más fácil tirar de ella. Tira en vertical hacia arriba por ambos lados a la vez, suavemente pero con firmeza. Haz lo mismo con la otra faja.

- Si la membrana está muy vieja y deteriorada es posible que te quedes con parte de la faja entre los dedos, y un cachito de ella aún enchufada en el conector de la placa. Si es el caso, quita la parte de faja que se ha quedado en el conector y tírala, e iguala la otra parte con unas tijeras, para que quede horizontal y al volverla a meter en el conector hagan contacto todas las pistas.

- Para volver a enchufar cada faja en su respectivo conector, coge la faja con las dos manos como la otra vez, llevando la "pinza" lo más cerca posible del final de la faja. Preséntala al conector, cuidando de que las pistas que se ven de la faja coincidan con las chapitas metálicas presentes en el conector (en uno de ellos verás claramente esas chapitas porque están cara a tí, en el otro, están mirando hacia atrás). Cuando veas que coincidan, usa la pinza de tus dos manos para insertar la faja presionando en vertical y hacia abajo, haciendo la misma fuerza con las dos manos a la vez.

- La faja de la membrana del teclado es muy delicada (más si es una membrana original de la época) y se rompe casi con mirarla. Bajo ningún concepto la fuerces, tirando de la carcasa de arriba, o haciendo movimientos bruscos que la doblen demasiado.
Web: ZX Projects | Twitter: @zxprojects

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por mcleod_ideafix » Mar Jul 27, 2010 1:16 am

Antón_ escribió:2- No veo como se separa el cobertor de las gomas para poder acceder tanto a las propias gomas como a la membrana. ¿Tiene algún tipo de enganche o está pegado? ¿Cómo haceis para separalo vosotros?

La pieza de goma está debajo de la chapa metálica (faceplate) que contiene las letras serigrafiadas y el arco iris. Levantándola, tienes acceso a la pieza de goma, y debajo de ella, a la membrana de teclado.

Según el modelo (y quizás la fábrica donde se ensambló) de Spectrum, esa chapa metálica está unida a la carcasa de plástico de dos formas:
- Mediante cinta adhesiva de doble cara: el sistema más habitual. Ármate de paciencia y con un destornillador u otra forma de hacer palanca, ve despegando la chapa. A veces es cuestión de segundos, y otras veces, hay que ir con más cuidado porque está realmente pegada, y al hacer palanca se deforma la chapa, que es muy endeble.
- Mediante anclajes metálicos: lo he visto en muchas menos ocasiones. Esos anclajes salen por las mismas ranuras por las que salen las dos fajas de la membrana y tendrás que quitarlos (a veces esos anclajes están unidos a la chapa metálica con pegamento o cinta adhesiva de doble cara) para poder levantar la chapa.
Web: ZX Projects | Twitter: @zxprojects

Antón_
rst 0
Mensajes: 7
Registrado: Vie Jul 23, 2010 2:52 pm

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por Antón_ » Mar Jul 27, 2010 7:37 pm

Bueno, pues antes de ponerme a medir continuidades y demás asuntos, me he puesto a abrir el spectrum 16kb para acceder a la membrana. Y muchas gracias a mcleod_ideafix por que sus indicaciones fueron perfectas para conseguirlo. Os comento mi experiencia, ayudado de unas fotos, por si pueden serle de utilidad a alguien en el futuro.

Lo primero que hice fue separarlas del bus. En efecto, cogiendo las fajas con dos dedos y tirando con firmeza (que no fuerte ni de un tirón) salen sin problemas. Y ya me di cuenta de que el problema estaba en la membrana, ya que la grande estaba así...
Imagen

y la más estrecha estaba rota en el propio bus.
Imagen

Así que no me quedaba más remedio que quitar la placa protectora del teclado si o si, ya que iba a tener que sustituirla. Como muy bien apuntó mcleod_ideafix, la placa va pegada al spectrum. Y para separarla, mi consejo es que aprovecheis el calor, para reblandecer el pegamento. Yo he optado por darle poco a poco con un secador, yendo por partes y con muuuuucha calma. Tened en cuenta que la chapa protectora es muy fina y blanda, con lo que si haceis fuerza vais a acabar doblandola. Y seguro que luego volver a colocarla bien no funcionará.

Con mucha paciencia, y la ayuda de un destornillador fino, de esos llamados "de relojero" he ido poco a poco dandole calor y haciendo UN POCO de palanca. Más que fuerza es una cuestión de maña, ir deslizando despacio el destornillador, escuchando como cruje el pegamento. Si en algún momento notamos algo de resistencia, vuelta a darle calor. Aquí, una imagen del proceso de separado:
Imagen

Y finalmente, despues de unos cuantos minutos, tenemos por fin separado el spectrum de la placa. Fijaos en los restos de pegamento en la placa: lleva tanto en los laterales como en la parte superior e inferior!
Imagen

El unico percance que tuve, fue por no seguir mi propio consejo. En un momento se me fue el destornillador y ahí esta la marca, para recordarme de por vida que es mejor ir con calma.
Imagen

Así que no me queda otra que comprar una nueva membrana. He intentado hacerlo en 'ZX spares', pero la web funciona muy mal, y no contestan a los mails. Mi intención era comprarla a algún vendedor de España, pero visto el éxito ¿cual me recomendais por vuestra experiencia en cuanto a calidad de la membrana, precio y fiabilidad del vendedor?

Un saludo y gracias a todos por ayudarme a reparar este pequeño gomas.

P.D. Me han dicho en otro foro, que los zocalos libres son para la expansión de memoria de 16 a 48. ¿Es esto posible? ¿Tiene alguna complicación el proceso de ampliación?

Avatar de Usuario
JULIO
Freddy Hardest
Mensajes: 588
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por JULIO » Mar Jul 27, 2010 9:34 pm

Hola, la complicación es encontrar RAM que te valga, de 64kbx1, tipo 4164.
aunque si eres manitas, ¿Porqué no hacer un 128kb?
Como hay que quitar la ram alta, y en
este caso es que no la tienes, te va a resultar mas facil encontrar una ram de 128kb tipo
628128 y la GAL te la programan en la tienda donde la compres. es el fichero *.jed.
enlace....
http://velesoft.speccy.cz/zx/external_128kb_upgrade/index.htm

vendedores españoles, está Stalvs.

en el extranjero rwap, sintech... es increible tenemos hasta reemplazo de la chapa,
la llaman "faceplate", por si la tienes muy arañada.

saludos
Julio.

Avatar de Usuario
winston
Sabreman
Mensajes: 469
Registrado: Mar Ago 19, 2008 4:17 pm
Ubicación: Isla de Man
Contactar:

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por winston » Mar Jul 27, 2010 11:50 pm

Los membranas de RWAP son de muy buena calidad, hace un mes he tenido que comprar uno.
Tarjeta ethernet para el Spectrum - http://spectrum.alioth.net/doc

Debemos practicar un quirkafleeg

Antón_
rst 0
Mensajes: 7
Registrado: Vie Jul 23, 2010 2:52 pm

Re: ZX Spectrum 16k arranca pero no hace más

Mensaje por Antón_ » Jue Jul 29, 2010 1:37 pm

Bueno, veo que lo de la memoria es un lio, así que no voy a hacerlo. Al fin y al cabo, lo que quiero es ponerlo a funcionar como el primer día, no hacerle mil modificaciones (aunque igual le hago la de la señal de video).

Finalmente creo que me voy a decantar por RWAP. Ya os contaré como ha sido el resultado.

Un saludo y gracias a todos por vuestros consejos.

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados