Problemas de color en un issue 6A

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Problemas de color en un issue 6A

Mensaje por fermars » Mié Dic 31, 2014 7:37 pm

Muy buenas a todos,

Tenía perfectamente funcionando mi Spectrum cuando no tengo ni idea de por qué se ha dejado de ver el color azul. La imagen se oscurece bastante; cuando meto un BORDER 1 se ve rojizo.
Pensaba que era el integrado IC14 pero lo he cambiado por otro y el síntoma es el mismo. Podría ser también un problema de que no le llegara bien la tensión de 12V pero he medido en distintos puntos según el esquema y las tensiones de 12V parece que están donde deben. Si quito el integrado se ve en B&N perfectamente. He cambiado también la ULA por si tuviera algún problema en la generación de señales U y V (creo que es la ULA quien se encarga) y tampoco hay cambio.

La verdad es que el problema parece una tontería, pero llegados a este punto y con estas comprobaciones no se por donde tirar ¿alguna idea?
Fernando

Avatar de Usuario
GLAURUNG
Jack The Nipper
Mensajes: 195
Registrado: Lun Oct 14, 2013 7:41 am

Re: Problemas de color en un issue 6A

Mensaje por GLAURUNG » Mié Dic 31, 2014 8:25 pm

A ver si es el oscilador :? o alguna soldadura o condensador :?:
Descárgate gratis GLAUZONE, un juego diferente https://drive.google.com/file/d/0BykJPZ ... sp=sharing
Imagen

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por fermars » Mié Dic 31, 2014 8:29 pm

GLAURUNG escribió:A ver si es el oscilador :? o alguna soldadura o condensador :?:

Gracias. Los condensadores los he cambiado todos por nuevos esta misma tarde y despues de hacerlo todo ha ido bien. He mirado tambien soldaduras y he repasado todas las que he visto chungas...¿El oscilador podria provocar algo asi?
Fernando

Avatar de Usuario
GLAURUNG
Jack The Nipper
Mensajes: 195
Registrado: Lun Oct 14, 2013 7:41 am

Re: Problemas de color en un issue 6A

Mensaje por GLAURUNG » Mié Dic 31, 2014 8:32 pm

fermars escribió:
GLAURUNG escribió:A ver si es el oscilador :? o alguna soldadura o condensador :?:

Gracias. Los condensadores los he cambiado todos por nuevos esta misma tarde y despues de hacerlo todo ha ido bien. He mirado tambien soldaduras y he repasado todas las que he visto chungas...¿El oscilador podria provocar algo asi?
Podria, o lo mismo te has llevado alguna pista cacharreando :?:
Descárgate gratis GLAUZONE, un juego diferente https://drive.google.com/file/d/0BykJPZ ... sp=sharing
Imagen

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por fermars » Mié Dic 31, 2014 9:01 pm

Si ese fuera el caso, necesito algo de ayuda para saber qué señal falta para que no se vea en color o la señal de crominancia esté "defectuosa", está claro que algún componente (o pista) no está haciendo bien su trabajo pero no se por donde empezar.
Bueno, vamos a dejarlo hasta el año que viene :D Jejeje. Feliz año.
Fernando

Avatar de Usuario
GLAURUNG
Jack The Nipper
Mensajes: 195
Registrado: Lun Oct 14, 2013 7:41 am

Re: Problemas de color en un issue 6A

Mensaje por GLAURUNG » Jue Ene 01, 2015 1:19 am

fermars escribió:Si ese fuera el caso, necesito algo de ayuda para saber qué señal falta para que no se vea en color o la señal de crominancia esté "defectuosa", está claro que algún componente (o pista) no está haciendo bien su trabajo pero no se por donde empezar.
Bueno, vamos a dejarlo hasta el año que viene :D Jejeje. Feliz año.
Feliz año!!
Habrá que bajarse el esquema y comprobar también las señales RGB que salen de la ULA, a ver donde está el corte, quizás algún transistor amplificador ha cascado. Ya tienes varias cosas sospechosas para ir mirando :D
Saludos.
Descárgate gratis GLAUZONE, un juego diferente https://drive.google.com/file/d/0BykJPZ ... sp=sharing
Imagen

Avatar de Usuario
eltargui
Jack The Nipper
Mensajes: 140
Registrado: Vie Feb 14, 2014 1:43 pm
Ubicación: Las Rozas de Madrid

Re: Problemas de color en un issue 6A

Mensaje por eltargui » Jue Ene 01, 2015 1:37 pm

Hola,
Echale un vistazo a este articulo a ver si te ayuda.
http://trastero.speccy.org/cosas/droy/a ... en_mal.htm
Puede haber varios candidatos a revisar.

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por fermars » Jue Ene 01, 2015 1:55 pm

eltargui escribió:Hola,
Echale un vistazo a este articulo a ver si te ayuda.
http://trastero.speccy.org/cosas/droy/a ... en_mal.htm
Puede haber varios candidatos a revisar.
Muchas gracias, voy a echarle un vistazo :)
Fernando

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por fermars » Jue Ene 01, 2015 10:42 pm

Solucionado.
Gracias al enlace que me ha pasado eltargui ha sido como seguir un paso a paso hasta dar con la avería, no había escapatoria :).
Al final ha sido el TR8 que ¡tenía la pata de base rota! y no hacía contacto. Supongo que ya estaría así pero con el cambio de los condensadores debió moverse el transistor y dejó de hacer contacto y de funcionar.

Confieso que me costó más de lo que parece. Como a mi la señal que me faltaba era la B-Y cambié el TR9 y también el cristal X2 pero seguía con el mismo síntoma. Al final no se cómo sucedió que también dejó de funcionar R-Y y fue cuando desoldé el TR8 y vi lo que había pasado. En fin, que por una parte me alegro de que pasara porque ahora se bastante más que antes y además he podido estrenar mi recién comprado osciloscopio digital.

Saludos y gracias!
Fernando

Avatar de Usuario
GLAURUNG
Jack The Nipper
Mensajes: 195
Registrado: Lun Oct 14, 2013 7:41 am

Re: Problemas de color en un issue 6A

Mensaje por GLAURUNG » Vie Ene 02, 2015 12:15 am

Me alegra que hayas podido solucionarlo gracias a ese "milagroso" enlace.
Saludos.
Descárgate gratis GLAUZONE, un juego diferente https://drive.google.com/file/d/0BykJPZ ... sp=sharing
Imagen

wazemak
rst 0
Mensajes: 37
Registrado: Mar Dic 23, 2014 2:22 pm

Re: Problemas de color en un issue 6A

Mensaje por wazemak » Dom Ene 04, 2015 10:40 pm

Hola,
Tengo un problemilla con mi 48k. Hasta ahora iba bien pero desde hace unos días cuando lo enchufo sale bien el logo de sinclair pero en vez de salir la pantalla blanca sale casi toda magenta. El borde sale bien. He probado los demás colores y alguno que otro sale mal ( cambiado) . Qué puede ser?

Mil gracias.

Avatar de Usuario
mcleod_ideafix
Johnny Jones
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por mcleod_ideafix » Lun Ene 05, 2015 2:33 am

¿Qué versión de placa (issue) es?
Web: ZX Projects | Twitter: @zxprojects

wazemak
rst 0
Mensajes: 37
Registrado: Mar Dic 23, 2014 2:22 pm

Re: Problemas de color en un issue 6A

Mensaje por wazemak » Lun Ene 05, 2015 9:56 am

Perdona mi ignorancia. Donde viene lo del issue?

Gracias

Avatar de Usuario
fermars
Freddy Hardest
Mensajes: 555
Registrado: Mié Abr 25, 2012 7:09 am
Ubicación: Madrid
Contactar:

Re: Problemas de color en un issue 6A

Mensaje por fermars » Lun Ene 05, 2015 10:09 am

wazemak escribió:Perdona mi ignorancia. Donde viene lo del issue?

Gracias
Con la placa fuera, justo a la izquierda del altavoz (debajo en el márgen) tienes una serigrafía en blanco que pone ISSUE XX. Lo que quiere saber mcleod es el valor de esas "XX". También puedes poner una foto de la placa y listo :)
Fernando

wazemak
rst 0
Mensajes: 37
Registrado: Mar Dic 23, 2014 2:22 pm

Re: Problemas de color en un issue 6A

Mensaje por wazemak » Lun Ene 05, 2015 10:21 am

Ya está: ISSUE 6A

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 6 invitados