Mi Spectrum 48K ha amanecido asi :(

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Responder
Avatar de Usuario
robocop48
Jack The Nipper
Mensajes: 133
Registrado: Mar Sep 18, 2007 1:40 pm

Mi Spectrum 48K ha amanecido asi :(

Mensaje por robocop48 » Sab Sep 21, 2019 10:47 pm

Buenas a todos,

Esta mañana tenía un rato libre y he conectado mi Spectrum 48K para jugar al Renegade (qué cosas!).

Y me encuentro esto:
Imagen

Aparecen unas barras verticales con el logo de Sinclair.

Esto es lo que he sacado en claro:
-La ULA no está mala, ya que está probada en otro spectrum y funciona correctamente
-El diagnóstico de mi SMARTCARD no detecta RAM errónea, pero me avisa de que no hay IRQ
-La primera y última columna del teclado no van! La membrana es nueva y está verificada en otro ordenador.
Imagen

Parece claro que es un problema de la placa, pero por mucho que busco por aquí, no he encontrado una reparación similar.

Esta es la placa:
Imagen

Gracias por vuestra ayuda!!

Avatar de Usuario
Kyp
Sabreman
Mensajes: 391
Registrado: Lun Dic 16, 2013 6:16 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por Kyp » Dom Sep 22, 2019 4:41 pm

Parece que falla el bit 0 del bus de datos. Si la CPU lo lee bien debe ser que hay un mal contacto del pin correspondiente de la ULA, revisa el pin 18. Si está doblado ten mucho cuidado al enderezarlo.

Avatar de Usuario
robocop48
Jack The Nipper
Mensajes: 133
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por robocop48 » Dom Sep 22, 2019 9:13 pm

El caso es que la ULA está bien, y lo que más me mosquea es, aparte de las barras, que las columnas de los extremos del teclado han dejado de funcionar

Saludos!!

drasero
rst 0
Mensajes: 7
Registrado: Jue Jun 07, 2018 1:37 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por drasero » Lun Sep 23, 2019 9:49 am

hola,

has probado encender el Spectrum sin el teclado conectado? Por verificar que la membrana no esté haciendo corto.

saludos,

David

Avatar de Usuario
Kyp
Sabreman
Mensajes: 391
Registrado: Lun Dic 16, 2013 6:16 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por Kyp » Lun Sep 23, 2019 9:55 am

robocop48 escribió:El caso es que la ULA está bien, y lo que más me mosquea es, aparte de las barras, que las columnas de los extremos del teclado han dejado de funcionar
Justamente, ese pixel y las columnas del teclado son cosa del bit 0 del bus de datos. Revisa la conexión de ese pin y las pistas que van desde ese pìn de la ULA al resto del circuito, que va a IC6 y a R1. Y revisa también R1. IC6 estará bien porque pasa los tests.

Avatar de Usuario
robocop48
Jack The Nipper
Mensajes: 133
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por robocop48 » Lun Sep 23, 2019 4:29 pm

drasero escribió:Has probado encender el Spectrum sin el teclado conectado? Por verificar que la membrana no esté haciendo corto
Está probado y el efecto sigue siendo el mismo.
Kyp escribió:
robocop48 escribió:El caso es que la ULA está bien, y lo que más me mosquea es, aparte de las barras, que las columnas de los extremos del teclado han dejado de funcionar
Justamente, ese pixel y las columnas del teclado son cosa del bit 0 del bus de datos. Revisa la conexión de ese pin y las pistas que van desde ese pìn de la ULA al resto del circuito, que va a IC6 y a R1. Y revisa también R1. IC6 estará bien porque pasa los tests.
Algo de eso tiene pinta de ser. Voy a comprobar la continuidad desde el pin 18 al resto del circuito, pasando por R1.

Saludos!!

Avatar de Usuario
Bone
Jack The Nipper
Mensajes: 132
Registrado: Mar May 20, 2008 12:22 pm
Ubicación: Mareny de Barraquetes

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por Bone » Lun Sep 23, 2019 6:20 pm

Veo que le has cambiado los condensadores. ¿hace mucho de eso? Lo digo porque estas placas no llevan mascara de soldadura, o sea, que las pistas estan al aire y cualquier residuo de estaño puede estar haciendo corto por ahí. A veces pasa que se suelta algún perdigón al cabo se un tiempo y suceden cosas así, que de repente deja de funcionar bien.
Repasa si puedes que no hayan residuos.
< Sistema preparado >

Avatar de Usuario
robocop48
Jack The Nipper
Mensajes: 133
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por robocop48 » Mar Sep 24, 2019 10:58 pm

Buenas noches!

Efectivamente, un trocito de estaño estaba atascado en el zócalo de la ULA, y estaba creando un corto en la pista que sale del pin 18.

Ha sido un trabajo de chinos hasta encontrar el dichoso fallo (era muy pequeño el joio!!), pero en cuanto he retirado el estaño, todo ha vuelto a la normalidad!!

Y ahora sí, a recuperar el tiempo perdido :D :D

Imagen

Gracias a todos!!

Avatar de Usuario
Bone
Jack The Nipper
Mensajes: 132
Registrado: Mar May 20, 2008 12:22 pm
Ubicación: Mareny de Barraquetes

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por Bone » Mié Sep 25, 2019 12:24 am

Fenomenal !! Ahora a disfrutar tocan !!!
< Sistema preparado >

Avatar de Usuario
Kyp
Sabreman
Mensajes: 391
Registrado: Lun Dic 16, 2013 6:16 pm

Re: Mi Spectrum 48K ha amanecido asi :(

Mensaje por Kyp » Mié Sep 25, 2019 9:41 am

¡¡ Felicidades !! :D :D :D

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 5 invitados