ZX Spectrum +3 no arranca al menú

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Responder
Avatar de Usuario
Zeit
Herbert
Mensajes: 84
Registrado: Jue Oct 22, 2009 1:49 am
Ubicación: Montevideo, Uruguay
Contactar:

ZX Spectrum +3 no arranca al menú

Mensaje por Zeit » Lun Abr 13, 2020 5:16 pm

Buenas a todos!

Luego de un largo, largo tiempo de no postear en este foro (si leerlo casi a diario), he comenzado, luego de varias paternidades en mí vida que me han insumido tiempo más que considerable, he comenzado luego del año pasado, y habiendo sido partícipe y organizador de la primera "ZX Hackaton" (evento similar a RetroMadrid pero a mucho más pequeña escala) de mi país, me he sumergido de lleno en el cacharreo y disfrute de las máquinas que Sinclair nos ha legado, realizadole varios mods.

Esto ha hecho que comience a reflotar mi colección personal de máquinas.

Tengo por el momento solo 2 de ellas que están dando problemas. Una ZX Spectrum +2B (la carcaza dice "+2A" pero la placa es la de un +2B) que presenta el típico problema de RAM, será solo cambiarlas, y luego proyecto colocarle una CF interna y usar otras ROM's.

La última en intentar revivir es la ZX Spectrum +3, destinada a colocarle una Gotek y el sistema OSD del proyecto Flash Floppy (ya lo he colocado en una Amiga 500 con excelente resultado).

Tocó el turno a desempolvarla, y lo primero fue conectar el transformador en vacío para prevenir cualquier cosa, y medir sus voltajes.

Todos los voltajes daban correctos, salvo la línea de -12V que no daba voltaje alguno. No es necesaria a menos de usar RS232 o MIDI en la máquina, cosa que no tengo prevista. Luego de un rato, de volver a testear los voltajes, tocó turno a conectar la +3

Uso un monitor 1080 de Commodore (el habitual de Amiga, pero con audio mono, a diferencia del 1084S) y el cable RGB que ya usaba para conectarlo a la 128 "toastrack".

Como medida de prueba habitual en las 128, siempre trato de arrancarlas pulsando "BREAK" y reset, de modo de ver la carta de colores y escuchar el sonido. Prueba satisfactoria :

Imagen

(La cervecita está acompañando el cacharreo y la cuarentena)

Peeero... al arrancar normalmente, la diskettera gira, se muestra el menú de inicio unos segundos, la diskettera sigue girando sin parar luego. Desconecto, y al reconectar, aparece esto y de ahí no pasa :

Imagen

La diskettera ya no gira al arrancar la máquina.

Me decanto por usar el test incorporado en la ROM, viendo que si quizá es un problema de ROM no arrancaría :

Imagen

Y pasa todos los test correctamente hasta llegar al de disco, donde no puede seguir adelante.

Cambio la fuente por la de una +2B, mismo resultado.

Desconecto la diskettera, lo mismo.

Intercambio las ROM por las de una +2B funcional, sigue pasando lo mismo

Cabe decir que testeo si algun chip está caliente de mas, solamente el controlador de la diskettera cuando está conectada da mas temperatura de la normal.

Normalmente, sin diskettera conectada la +3 debería arrancar.

El FDC va conectado al separador de datos, quizá ese sea el problema, aunque hay unos 74xxx que forman parte de ese circuito que quizá sean los culpables.

Me ha desorientado por completo este tema ya que no había visto falla similar.

Agradezco si alguien puede echarme algún cable en este tema ó si ha tenido algún problema similar.

Long Live ZX Spectrum!
8 bits forever!

carmeloco
Sabreman
Mensajes: 436
Registrado: Vie Mar 21, 2008 8:24 pm

Re: ZX Spectrum +3 no arranca al menú

Mensaje por carmeloco » Mar Abr 14, 2020 1:42 am

A mi me pasó algo asi con un +3, y resultó ser el controlador de disketera.

Avatar de Usuario
Zeit
Herbert
Mensajes: 84
Registrado: Jue Oct 22, 2009 1:49 am
Ubicación: Montevideo, Uruguay
Contactar:

Re: ZX Spectrum +3 no arranca al menú

Mensaje por Zeit » Jue Ene 07, 2021 7:20 pm

carmeloco escribió:
Mar Abr 14, 2020 1:42 am
A mi me pasó algo asi con un +3, y resultó ser el controlador de disketera.
Pues parecería ser que sí : el chip calentaba mucho. Para cerciorarme tomé el camino rápido de prueba. Corté la pata de VCC del chip, y la máquina arrancó en modo +2A, lo cual supongo correcto al no detectar diskettera conectada.

En vista de eso, procedí a desoldar el chip, y colocar socket correspondiente. Aquí vino el problema. Usando pistola de calor para desoldar los chips, recalenté una de las RAM próximas al controlador. El resultado fue que la máquina no arrancó más presentando patrón que supongo sería de RAM quemada. Lo más cercano a lo que presenta es esta imagen que tomé de un post :

Imagen

Aunque el borde es negro muchas veces, puede llegar a presentarse como esto :

Imagen

Luego de soldar zócalo del controlador y colocar otro para la memoria achicharrada, y cambiada la memoria y la controladora del FDD el problema persiste, siendo una imagen errática a veces, pero la mayoría de las veces hace el proceso de inicio y al llegar al menú (sin mostrarlo) queda absolutamente en negro la pantalla.

Me encuentro completamente desorientado... ¿alguna idea?
He comprobado como "señal de vida" que el clock en la pata del Z80 pulsa correctamente.
Gracias de antemano!
8 bits forever!

carmeloco
Sabreman
Mensajes: 436
Registrado: Vie Mar 21, 2008 8:24 pm

Re: ZX Spectrum +3 no arranca al menú

Mensaje por carmeloco » Sab Ene 09, 2021 11:58 am

Es posible que hayan más chips de ram mal. Están bastante cerca entre ellos, y si uno ha cascado por exceso de calor, es muy posible que el que esté al lado, también esté mal.
En este modelo, también te puede ayudar el siguiente procedimiento:
https://www.zonadepruebas.com/viewtopic ... 448#p28442

Avatar de Usuario
Zeit
Herbert
Mensajes: 84
Registrado: Jue Oct 22, 2009 1:49 am
Ubicación: Montevideo, Uruguay
Contactar:

Re: ZX Spectrum +3 no arranca al menú

Mensaje por Zeit » Mar Ene 19, 2021 2:07 pm

Estuve chequeando todo, cambiando de a uno los chips de RAM. La máquina sigue sin arrancar, pero lo malo es que la ULA comenzó a levantar temperatura. Creo es hora de darle cristiana sepultura a mi +3 :(
8 bits forever!

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 4 invitados