Portátil ZXSpectrum Gomas,¿misión imposible? NO, CONSEGUIDO!

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Portátil ZXSpectrum Gomas,¿misión imposible? NO, CONSEGUIDO!

Notapor Mobutu16 el Lun May 02, 2011 2:23 pm

A la buena de Dios!.

Hace algunas semanas y ahora que tengo un poco de tiempo he iniciciado el proyecto del cojo-portatil. Y despues de analizar los gastos de Amperaje (o intensidad s/Scooter :D )....
...Esto es lo que llevo hecho hasta ahora
1.- Cambiado 7805 por tracopower asi quitamos disipador y reducimos bastante los W y en definitiva los A
2.- Anulamos modulador TV y dejamos sólo salida de Video...y por lo tanto ya no necesitamos la caja de modulación y es extraída.
3.- Cambiamos tr4 por ztx651 y así podemos ampliar el rango de intensidad soportado a 2A
4.- Después de un soplo, incorporo 2 condesadores 16v 100 al lm889, patillas 14 y 16 ya puedo ver mejor y reducimos al máximo el ruido en pantalla
5.- Sustitución de los 4116 por 4164 de la Vram y ya no necesitaremos más los +12 y -5 (sólo quedaría el +12 en el lm889)
6.- Sustitución de los 8 integrados de la Ram por un único IC de 32K SRAM D43256BCZ-70LL. Se quitan también los lógicos IC25 y 26.

Imagen

En éste último punto es donde tengo problemas, ya que tengo que soldar la SRAM encima de la ROM y dejar 3 patillas al aire de la SRAM, 2 van al Z80 y la tercera al IC23. El spectrum arrancaba perfectamente, pero sólo me reconoce 16K. Pensando que estaba la SRAM mal, le puse otra, lo mismo. Le hice el peek de memoria y me daba 32767, 1 bit más de los 16k (32766), por lo tanto estaba seguro que la SRAM estaban mal...pues NO!!!!, al dejarlo todo como estaba, y sin dejar rastro de sran ni cables ni soldaduras, seguía sin reconocerme los 48k!!!!. Luego por alguna razón algo ha petado, He cambiado los IC23, 24, 25 y 26 y la RAM alta por otros ICs que tengo de un donante (el donante da perfectamente 48K), y sigue igual. He cambiado por si las moscas el Z80, y lo mismo...
...¿es posible que haya dañado la ROM o tenga un corto?

Si es así y ya que el donante está en placa soldado, ¿que Eprom o Eeprom me recomendáis?

...y lo que es más importante, ¿cómo es posible que haya fastidiado la ROM?¿calor de soldadura, algún corto,?
...y para finalizar, ¿tenéis el fix de Sami funcionando bien?

Gracias!!
Ultima edición por Mobutu16 el Lun Jun 27, 2011 10:08 pm, editado 2 veces en total
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Lun May 02, 2011 5:20 pm

Mobutu16 escribió:soldar la SRAM encima de la ROM y dejar 3 patillas al aire de la SRAM, 2 van al Z80 y la tercera al IC23.


¿Exactamente cómo lo has hecho? ¿Qué patillas de la SRAM has puesto a qué patillas del resto de la placa?
Si la SRAM es... "estándar", por ejemplo, una 62256, tendrá un pin CE, otro OE y otro WE.
Tal y como lo veo, creo que el pin WE de la SRAM irá a WE del Z80. el de OE puede ir a RD, y el de CE, al pin 8 de IC23, pero habiendo suprimido antes la célula de retardo que ya no hace falta, es decir, quitando C63. Para evitar problemas de fan-out en el pin 8, los dos multiplexores 74LS157 deberían retirarse, y en un momento dado podría ser recomendable sustituir IC23 de un 74LS32 a un 74HCT32, aunque no creo que haga falta.

Mobutu16 escribió:Le hice el peek de memoria y me daba 32767

Hubiera sido mejor si después de comprobar la memoria disponible y ver que llegas a 32767 haces un PAUSE 1: POKE 32768,0: PRINT PEEK 32768. Si ves 255 es que tu memoria no está siendo seleccionada en absoluto. Si ves un valor distinto de 0 pero distinto de 255 entonces es que algunas líneas del bus de datos no están bien soldadas.

Mobutu16 escribió:...y lo que es más importante, ¿cómo es posible que haya fastidiado la ROM?¿calor de soldadura, algún corto,?

No lo creo. Si hubieras fastidiado la ROM el aparato no arrancaría en absoluto.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Lun May 02, 2011 8:01 pm

mcleod_ideafix escribió:¿Exactamente cómo lo has hecho? ¿Qué patillas de la SRAM has puesto a qué patillas del resto de la placa?
Si la SRAM es... "estándar", por ejemplo, una 62256, tendrá un pin CE, otro OE y otro WE.
Tal y como lo veo, creo que el pin WE de la SRAM irá a WE del Z80. el de OE puede ir a RD, y el de CE, al pin 8 de IC23, pero habiendo suprimido antes la célula de retardo que ya no hace falta, es decir, quitando C63. Para evitar problemas de fan-out en el pin 8, los dos multiplexores 74LS157 deberían retirarse, y en un momento dado podría ser recomendable sustituir IC23 de un 74LS32 a un 74HCT32, aunque no creo que haga falta.


La RAM es una 32K SRAM D43256BCZ-70LL

Pin 1 de la SRAM a pin 4 del Z80
Pin 27 de la SRAM a pin 22 del Z80
Pin 20 de la SRAM a pin 6 del IC23

Estas 3 patillas de la SRAM están levantadas y no hacen contacto con la ROM, el resto de patillas están soldadas a la ROM
Los IC25 e IC26 junto con las 8 upper Ram chips, fuera.


mcleod_ideafix escribió:Hubiera sido mejor si después de comprobar la memoria disponible y ver que llegas a 32767 haces un PAUSE 1: POKE 32768,0: PRINT PEEK 32768. Si ves 255 es que tu memoria no está siendo seleccionada en absoluto. Si ves un valor distinto de 0 pero distinto de 255 entonces es que algunas líneas del bus de datos no están bien soldadas.


Así lo haré. De todas formas acabo de desoldar la ROM para ponerla en socket y trabajar con la SRAM encima mucho mejor. Tan pronto ponga el socket, lo haré.


mcleod_ideafix escribió:No lo creo. Si hubieras fastidiado la ROM el aparato no arrancaría en absoluto.


Eso creía, pero no viene de más preguntarlo.

Tengo la sensación que si cambiando los IC23 al IC26 y los 8 chips de la RAM de otro Spectrum que va perfectamente y sigo viendo los 32767, alguna resistencia,diodo o condensador están fritos.

Estoy revisando una a una y he empezado por las resistencias y me he encontrado que de la R9 a la R16 me da 4K4 en vez de 8K2 y la R54 en vez de 100K me da 23K.
Desgraciadamente no puedo medir los condensadores ni sé cómo medir los diodos....tela como sea uno de ellos.

Realmente lo que me preocupa es si el Fix de la SRAM está fastidiando algo, y que por mucho que cambie resistencias o lo que sea, me seguirá fastidiando el tema.

Por otro lado no se si me curaría en salud cambiando la Upper RAM por 2 64x4... :?:

Muchísimas gracias!!
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Lun May 02, 2011 8:23 pm

Mobutu16 escribió:La RAM es una 32K SRAM D43256BCZ-70LL

Pin 1 de la SRAM a pin 4 del Z80
Pin 27 de la SRAM a pin 22 del Z80
Pin 20 de la SRAM a pin 6 del IC23


El pin 6 da una señal activa en bajo mucho tiempo después de que comience el ciclo de bus. Creo que en el pin 8, quitando el condensador como te dije, tendrás más tiempo para direccionar la SRAM. Por lo demás, todo parece estar en orden :D

Mobutu16 escribió:Tengo la sensación que si cambiando los IC23 al IC26 y los 8 chips de la RAM de otro Spectrum que va perfectamente y sigo viendo los 32767, alguna resistencia,diodo o condensador están fritos.

Estoy revisando una a una y he empezado por las resistencias y me he encontrado que de la R9 a la R16 me da 4K4 en vez de 8K2 y la R54 en vez de 100K me da 23K.


¿Estás midiendo con la resistencia soldada a la placa? Porque si es así, la medida que obtengas no es en absoluto fiable, ya que no estás teniendo en cuenta las derivaciones de resistencia en paralelo. De todas formas, si es un equipo que antes iba y después de trastear ya no, no buscaría resistencias o condensadores "quemados", ya que la intensidad que pasa por ellos en esas líneas es del orden de decenas de microamperios. El componente, ni se entera :D

Mobutu16 escribió:ni sé cómo medir los diodos....tela como sea uno de ellos.

Con el polímetro en modo "medir continuidad" (eso que cuando unes las dos puntas salta un pitido). De todas formas, dudo que sea eso.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Lun May 02, 2011 9:36 pm

Así lo haré, cambiaré al pin 8 y quitaré el C63.

De lo demás si no son los Ic23,24,25,26, ni las 4532, ni la rom ni z80 ni ula, ni condensadores ni Resistencias. Sólo quedan los diodos, ¿No?. Hasta iniciar el trapicheo con la SRAM, únicamente había cambiado el TR4 y el 7805 por el Tracopower.

...ahora ya si que estoy perdido, aunque en el fondo me alegro de no tener que desoldar una a una las resistencias y condensadores...

Ya no duermo... :lol:
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Lun May 02, 2011 10:08 pm

Mobutu16 escribió:Sólo quedan los diodos, ¿No?.

Tampoco creo que se hayan dañado. La cosa creo que va más por alguna pista que se haya quedado mal soldada al ponerle el zócalo a la ROM, o alguna cosa de estas. De todas formas, si me dices que tal y como está, funciona, salvo que no reconoce los 32K superiores, entonces creo que deberías repasar tu montaje.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Lun May 02, 2011 11:01 pm

Efectivamente no reconoce los 32k ni de coña. Todavía no he puesto zócalo a la ROM, ésta tarde la he quitado y limpiado bien de restos la placa, si los había, y todos los puntos de la ROM. Mañana pondré zócalo a la ROM y probaré primero con otra ROM que tengo.
Esperemos que sólo sea eso y repasaré continuidades de todas las memorias y ROM.

Seguiremos informando...Gracias, es siempre un placer leerte postees donde postees.

EDITO:quizás se me pasó decir que aunque no me reconozca los 32k, tampoco puedo hacer funcionar el divide, ya que se cuelga igual al ejecutar juegos de 16k...sale el fatware, sekecciono juego y al ejecutarlo se bloquea y resetea. Ahí por lo tanto nada tiene que ver las lógicas de 32k ni las memorias upper, por lo tanto es muy probable que haya algún corto por la Rom al haber soldado encima la Sram.
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Lun May 02, 2011 11:24 pm

Mobutu16 escribió:por lo tanto es muy probable que haya algún corto por la Rom al haber soldado encima la Sram.


Si la ROM tuviera un corto, en las pistas de datos o de direcciones, directamente no podrías arrancar el ordenador. Si llegas al (C)1982... significa que la ROM y el Z80 están bien, pero además significa que las líneas de datos y de direcciones no tienen cortos.

Si puedes grabar una EPROM y ponerla en lugar de la ROM en el Spectrum, ve a la "Retrowiki Magazine 1" y busca un artículo que escribí sobre la reparación de un +3. En ese articulo describo cómo funciona una ROM de testeo que hice para el Spectrum, y que igual te srive para testear el tuyo con y sin expansión de memoria.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Mar May 03, 2011 10:21 am

Ok, encontrado artículo y empapándome de él.

Para la eprom y viendo el artículo de José Leandro: http://www.speccy.org/trastero/cosas/JL/ROM-EPROM/ROM-EPROM.html, me voy a una 27C128, mejor, ¿no?

Seguimos con las pruebas. Gracias!!
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor KRYCEK el Mar May 03, 2011 11:50 pm

Un placer leeros a los 2 aunque no me entere de nada. :lol:

Deseando ver el invento final funcionando Mobutu. :D
Avatar de Usuario
KRYCEK
rst 0
 
Mensajes: 30
Registrado: Lun Jul 12, 2010 8:41 am

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Mie May 04, 2011 9:31 pm

Aunque no os lo creáis...era una falsa soldadura en el IC23 cuando puse el zócalo!!!!...qué razón tenías Mcleod...pues funciomando la SRAM!!!

...ahora el segundo lío...quitados los 4116 para poner zócalos y ponerles los 4164, me ha costado un montón sacarlos, ni chupón ni cobre...ufff, y despues de una hora y sacar algun Ic a lo bruto, he medido continuidades antes y despues de poner los zócalos y todo correcto...pero al volver a poner los 4116....pues la pantalla gris con lineas finas verticales y que cambia a reset, border blanco y paper negro, y vuelta a empezar con la pantalla gris...no creo que haya más problemas que la memoria, ¿no?

Luego pongo fotos de la SRAM.

Saludos

Pd: enas Krycek!!!
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Mie May 04, 2011 11:49 pm

Mobutu16 escribió:pero al volver a poner los 4116....pues la pantalla gris con lineas finas verticales

Repasa la alimentación de los 4116. ¿Todos reciben 12V y -5V?
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Jue May 05, 2011 5:32 pm

Efectivigüonder Mcleod...TR4 fuera, reemplazado por un ztx651, 4116 reemplazados por 4164 de 100ns con el fix descrito (patilla 8 cortada y enlazada a patilla 9) y así ha quedado el tema:

Imagen
Imagen

...enciendo con toda la ilusión...y....pitido y ésta imagen:

Imagen

Cambiado IC10, ha disminuido el número de cuadraditos en pantalla, por lo que posiblemente más de un IC me haya venido mal :?: , no creo que haya más problema que las memorias, no?

Gracias!!!!

EDITO: Cambiados IC13 e IC12 por antiguos 4116 y perfecto, me detecta perfectamente los 48K, ningún problema en pantalla, funciona perfectamente el ZXMatrix y el divIDE....tal y como queda ahora, está a medias el trabajo, los +12 siguen estando presentes aunque en sólo dos 4116...

Perdonar por la chapuzada de la SRAM dónde está puesta, pero puse zócalo en la ROM y no cerraba bien la carcasa si ponía encima la SRAM....no me quedaba otra alternativa...Sorry. :(
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor Mobutu16 el Mar May 10, 2011 7:47 pm

Bueno, terminada la primera parte!!!!!!, ya sólo queda poner la pantalla...a ver si me llega en uno de éstos días...

Hoy otro 4164 ha dejado de funcionar, y ya me parece extraño que de 10 comprados, ya se hayan fastidiado 5...si lo único que hacemos es quitarle el +12 y -5, debería ir mejor....¿es posible que al ser de 100 ns tenga problemas como vi en algún otro post?...por lo demás, no entiendo que después de 15 minutos de uso, salten pixels vagos aleatoriamente, claro síntoma del IC13...quizás debería de probar otros de menor velocidad. Sistituido por un antiguo 4116, y solucionado.

Aquí os dejo unas fotos:

ImagenImagenImagenImagen

He puesto el interruptor de encendido de batería quitando el MIC, ya que no me quedaba espacio. He metido un nuevo LED rojo y he abierto un nuevo hueco para el conector del cargador de la batería. Lo ideal habría sido ponerlo en el hueco de 9V pero no entraba por lo largo, ya que chocaba con la bobina y por lo ancho con el Tracopower...lástima.

Tal y como está el consumo en estos momentos es de 720mAH (Spectrum 48K+divIDE), unas 2 horas 40 minutos a plena carga. Sinceramente, pensaba que iba a ser menor la intensidad. Con el ZXMatrix la intensidad se reduce hasta los 480mAh, ideal para que con el monitor se vaya a unos 1400mAH.

En breve la 2ª parte con el monitor 7"...a ver qué tal el consumo...

Gracias mcleod_ideafix por tu inestimable ayuda.
Mobutu16
Herbert
 
Mensajes: 65
Registrado: Mar Mar 15, 2011 5:53 pm

Re: Portátil ZX Spectrum Gomas, ¿misión imposible?

Notapor mcleod_ideafix el Mie May 11, 2011 12:14 am

Mobutu16 escribió:Hoy otro 4164 ha dejado de funcionar, y ya me parece extraño que de 10 comprados, ya se hayan fastidiado 5...si lo único que hacemos es quitarle el +12 y -5, debería ir mejor....¿es posible que al ser de 100 ns tenga problemas como vi en algún otro post?...por lo demás, no entiendo que después de 15 minutos de uso, salten pixels vagos aleatoriamente, claro síntoma del IC13...quizás debería de probar otros de menor velocidad. Sistituido por un antiguo 4116, y solucionado.

A partir de 150ns (o menos) no debería dar ningún problema. A mi personalmente no me lo han dado incluso con chips de 200ns. Sin embargo, puede que el problema tenga que ver con esto otro que me pasó a mi hace tiempo:
viewtopic.php?f=8&t=360

Mobutu16 escribió:He puesto el interruptor de encendido de batería quitando el MIC, ya que no me quedaba espacio. He metido un nuevo LED rojo y he abierto un nuevo hueco para el conector del cargador de la batería. Lo ideal habría sido ponerlo en el hueco de 9V pero no entraba por lo largo, ya que chocaba con la bobina y por lo ancho con el Tracopower...lástima.

¿Botón de reset tiene? Aunque al no haber ningún 4116, el ciclo de alimentación no es tan crítico, todo lo que sea no estresar los componentes con ciclos de apagado-encendido innecesarios siempre es bueno. Si no hay botón de reset, creo que sería un añadido más que conveniente.

Mobutu16 escribió:Tal y como está el consumo en estos momentos es de 720mAH (Spectrum 48K+divIDE), unas 2 horas 40 minutos a plena carga. Sinceramente, pensaba que iba a ser menor la intensidad. Con el ZXMatrix la intensidad se reduce hasta los 480mAh, ideal para que con el monitor se vaya a unos 1400mAH.

Cambia los chips lógicos LS por unos de la serie HCT.
Cambia el Z80 por uno que sea versión CMOS en lugar del original NMOS.
La ROM, ¿es la original? Si es así, cambiala por una Flash EPROM CMOS.
Lo único que te seguirá consumiendo bastante corriente es la ULA, que de momento tendrás que dejarla ahí, pero con estos cambios deberías poder reducir el consumo unos 100-150mA menos de lo que tienes ahora.

Mobutu16 escribió:Gracias mcleod_ideafix por tu inestimable ayuda.

De nada :)
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3983
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Siguiente

Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 0 invitados