Reparando un 48K - Ayuda

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Reparando un 48K - Ayuda

Notapor robocop48 el Lun May 06, 2019 5:09 pm

Hola a todos,

Hace poco me dejaron un 48k, Placa Iss 4b, cuyo dueño hizo un apaño bastante extraño en la fuente de alimentación (cables pelados, polaridades cambiadas...), así que el petardazo tuvo que ser antológico, ya que el TR4 estaba fundido y he tenido que cambiarlo.

Una vez cambiado TR4, el ordenador no termina de arrancar. Siempre sale la misma pantalla, borde azul, franjas negras y blancas con basura y algunos cuadros con el flash activo. Foto aquí: https://ibb.co/T4PhYkT

He chequeado las tensiones y parece que todas están bien, así que no sé si habrá algo más que mirar.
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor carmeloco el Lun May 06, 2019 5:40 pm

Pues lo más seguro es que se haya llevado por delante varios chips de RAM. Un interface rom, con alguna rom de diagnóstico ayudaría también a ver más cosas.
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 431
Registrado: Vie Mar 21, 2008 9:24 pm

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Lun May 06, 2019 5:55 pm

carmeloco escribió: Un interface rom, con alguna rom de diagnóstico ayudaría también a ver más cosas.


Tengo un SMART CARD v2 de retroleum, pero éste no consigue arrancar la ROM de diagnóstico cuando lo conecto al spectrum... ¿Aparte de la RAM puede ser algo más que impida arrancar a la tarjeta de diagnóstico?

Saludos
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor mcleod_ideafix el Mar May 07, 2019 1:45 am

Los síntomas que describes apuntan a que el Z80 se ha estropeado también. Eso haría imposible usar cualquier tarjeta de diagnóstico.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3982
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Reparando un 48K - Ayuda

Notapor radiosity el Mie May 08, 2019 8:24 am

Antes de nada yo te recomendaria medir con un polimetro que tengas los voltajes correctos. Si te falla la linea de +12 puedes tener unos sintomas parecidos.
radiosity
rst 0
 
Mensajes: 26
Registrado: Dom Dic 15, 2013 10:10 am

Re: Reparando un 48K - Ayuda

Notapor llopis el Mie May 08, 2019 8:35 am

Así para empezar, yo probaría a dejarlo encendido unos minutos y mirar si se calienta algo excesivamente (que cueste dejar un dedo tocándolo). Si pasa eso, ese chip está para tirar y cambiar. Si no se calienta nada, tendrás que seguir mirando a ver qué puede pasar.
Muchas cosas pueden causar imágenes como las que estás viendo (Z80, RAM, ROM, o incluso la ULA). Pero si mcleod dice que te mires el Z80, empieza por ahí :-)
Avatar de Usuario
llopis
rst 0
 
Mensajes: 15
Registrado: Mar Sep 11, 2018 9:24 am
Ubicación: Asturias

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Mie May 08, 2019 5:55 pm

llopis escribió: Pero si mcleod dice que te mires el Z80, empieza por ahí :-)


Tomo nota!! Gracias! Mañana mismo me pongo con el desoldador, malla y pasta... a ver qué pasa.

Ya os cuento
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Dom Jun 16, 2019 4:15 pm

robocop48 escribió:
llopis escribió: Pero si mcleod dice que te mires el Z80, empieza por ahí :-)


Tomo nota!! Gracias! Mañana mismo me pongo con el desoldador, malla y pasta... a ver qué pasa.

Ya os cuento


Buenas de nuevo,

Tras unas semanas de espera, a llegaron los zócalos y el Z80. He retirado el z80 sospechoso y he colocado uno nuevo en su zócalo.
La cosa cambia, ahora, el ordenador tras una pequeña ráfaga en los bordes como si cargara en turbo(imposible capturarlo en una foto), se queda, normalmente, con el borde rojo, tal y como queda en la foto.
Imagen
Imagen

Ya ha cambiado algo, pero no se ha avanzado mucho. Al conectar la Smartcard, no ocurre nada identificable.

Eso si, chequeando las tensiones de los componentes más importantes, me he encontrado con que TR6 tiene en la base una tensión inusualmente alta, debería esperarse 1,78V y tengo sobre unos 4V ¿Esto indica algún problema en la "glue Logic"?

Saludos! Y gracias por vuestra ayuda
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Mie Jun 26, 2019 11:31 pm

Alguien puede aportar un poco de ayuda?? Gracias!!
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor Bone el Jue Jun 27, 2019 8:23 pm

Has probado lo que te apuntaba llopis sobre el calentamiento de los IC's? Te puede dar alguna pista...
Por lo demás, apunta a RAM frita...peeeeroo....si la ROM de diagnóstico no chuta, tambien podria ser algún multiplexor...
Vaya...hay muchas variables que pueden estar afectando de esa forma... :?
< Sistema preparado >
Avatar de Usuario
Bone
Jack The Nipper
 
Mensajes: 121
Registrado: Mar May 20, 2008 12:22 pm
Ubicación: Mareny de Barraquetes

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Jue Jun 27, 2019 9:56 pm

Bone escribió:Has probado lo que te apuntaba llopis sobre el calentamiento de los IC's? Te puede dar alguna pista...

Nada se calienta en exceso... así que va a tocar probar los multiplexores y demás a ver si falla algo

Me pongo a ello ;)
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Reparando un 48K - Ayuda

Notapor Kyp el Jue Jun 27, 2019 11:55 pm

robocop48 escribió:
robocop48 escribió:
llopis escribió: Pero si mcleod dice que te mires el Z80, empieza por ahí :-)

Eso si, chequeando las tensiones de los componentes más importantes, me he encontrado con que TR6 tiene en la base una tensión inusualmente alta, debería esperarse 1,78V y tengo sobre unos 4V ¿Esto indica algún problema en la "glue Logic"?

TR6 es el transistor que hace el OR entre IORQ y A0 para el puerto $FE de la ULA. Si no hay actividad ahí es que la CPU no está activa. Como la has cambiado yo me aseguraría primero de que funciona la ROM (quítala y usa solo la externa para salir de dudas) y que no falla la RAM baja (si tienes bien las tensiones de +12 y -5 es conseguir hacer funcionar una ROM de test). La ROM de Retroleum no se si funciona sin RAM (supongo que si), la de Brendam Alford seguro que si.
Avatar de Usuario
Kyp
Sabreman
 
Mensajes: 324
Registrado: Lun Dic 16, 2013 7:16 pm

Re: Reparando un 48K - Ayuda

Notapor radiosity el Sab Ago 17, 2019 1:17 pm

Yo insistiria. Si ha habido una movida con alterar polaridades y TR4 estaba mal es posible que aún no tengas en orden alguna de las tensiones de trabajo. Yo empezaria por el principio y una vez que descartes mal voltaje ponte a cambiar integrados.
radiosity
rst 0
 
Mensajes: 26
Registrado: Dom Dic 15, 2013 10:10 am

Re: Reparando un 48K - Ayuda

Notapor robocop48 el Dom Ago 18, 2019 8:12 pm

radiosity escribió:Yo insistiria. Si ha habido una movida con alterar polaridades y TR4 estaba mal es posible que aún no tengas en orden alguna de las tensiones de trabajo. Yo empezaria por el principio y una vez que descartes mal voltaje ponte a cambiar integrados.

Me parece más sensato empezar por revisar tensiones, ya que parece más sencillo.
Antes de hacer nada, voy a seguir los pasos indicados en el manual de servicio del Spectrum:
Imagen

En rojo las que podría medir, ya que solo tengo un polímetro. ¿Hay algún otro punto que tenga interés revisar?

Gracias por la ayuda
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 116
Registrado: Mar Sep 18, 2007 1:40 pm


Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: Google [Bot] y 4 invitados

cron