ULA sin señal de reloj

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Re: ULA sin señal de reloj

Notapor fenedan el Jue May 17, 2018 9:53 pm

jzx, he quitado finalmente la ROM y arrancado con el Interface de diagnóstico. Apareció el primer test pero justo después se colgó, así que parece que la ROM tampoco es la culpable.
Hace unos días mire algunas señales de la CPU, como la MREQ or RD y las señales no tienen ninguna variación, así que parece que el proceso se detiene por algún motivo.
Haré un examen más exhaustivo de todas los pines tanto de CPU como de memorias aunque tendré que hacerlo con el analizador ya que no tengo osciloscopio, ¡ a ver que tal ! ( tomo nota sobre los 4116 )
fenedan
rst 0
 
Mensajes: 7
Registrado: Sab May 05, 2018 3:36 pm

Re: ULA sin señal de reloj

Notapor jzx el Vie May 18, 2018 2:08 pm

fenedan escribió: mire algunas señales de la CPU, como la MREQ or RD y las señales no tienen ninguna variación


Si te refieres a que están a un nivel fijo, no es normal. Si hay varias que lo hacen no creo que sea un corto, podria ser que la cpu se pare. Esto puede ser por que se quede sin reloj, se active /wait o /busreq, que normalmente no se usan. Pon el analizador en estas señales, clk, /busreq, /wait, /mreq, /rd y a ver que hace, si se paran a ver como esta cada una

Tambien podria ser que el z80 esta mal
jzx
Freddy Hardest
 
Mensajes: 989
Registrado: Lun Feb 08, 2010 9:19 pm

Re: ULA sin señal de reloj

Notapor JULIO el Lun May 21, 2018 1:22 pm

Hola.
Si hay lineas que no varían, el Z80 está para cambiar.
En el tema de condensadores, es el punto de partida para hacer una reparación, sin voltajes estables el
osciloscopio o cualquier otro aparato para medir señales te puede dar valores que no valen para nada.
Una web interesante sobre el reemplazo de condensadores (in english) de Phil Ruston:
http://blog.retroleum.co.uk/electronics-articles/re-capping-the-spectrum/
Salvo que tengas una issue TWO que tiene un error en la serigrafía y puedes montar un condensador mal, el resto es sencillo.
Y te recomiendo que te hagas con el esquema de la issue que tengas, no es que cambie mucho de una a otra.

Al final parece que va a ser una reparación sencilla, cambiar el Z80.
saludos.
Julio.
Avatar de Usuario
JULIO
Freddy Hardest
 
Mensajes: 578
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ULA sin señal de reloj

Notapor JULIO el Mar May 29, 2018 10:40 pm

Hola.
¿Y que pasó, lo arreglaste?

saludos
Julio.
Avatar de Usuario
JULIO
Freddy Hardest
 
Mensajes: 578
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ULA sin señal de reloj

Notapor fenedan el Jue Jun 07, 2018 7:38 pm

Qué tal Julio, he andado muy liado y aún no he tenido tiempo de ponerme más a fondo. Hice un primer test mirando las señales de la CPU y le pasa algo muy extraño porque hay actividad en los buses de control y después de un segundo o dos, ¡caput! deja de haberla. Si la CPU estuviera muerta no reaccionaría desde el segundo 0, eso deduzco por lógica. De todas maneras tengo todos los condensadores para hacer el recap así que lo primero que haré, como me recomiendas, será sustituirlos todos y luego volver a mirar.
jzx, miré /wait y /busreq y no se activan ninguna de estas y la señal de reloj de la CPU no se detiene. Con respecto a las demás señales de control tendré que ponerme a mirar con más detalle porque todo parece ser normal hasta que pasado este breve tiempo deja de funcionar.
fenedan
rst 0
 
Mensajes: 7
Registrado: Sab May 05, 2018 3:36 pm

Re: ULA sin señal de reloj

Notapor jzx el Vie Jun 08, 2018 4:59 pm

Eso es muy raro. Y no son los condensadores ... mejor que no te metas a cambiar los condensadores hasta que no soluciones el problema de que se pare el procesador, porque a veces, con el desoldador puedes hacer algún corto entre dos pistas sin darte cuenta, y volverte loco para encontrar el fallo teniendo el fallo original y uno o dos cortos por las soldaduras.

Si se paran todas las señales del z80, eso en un z80 normal sólo puede ser la alimentación, que no hay reloj, reset, busrq o wait. Mira con un polimetro las tensiones de estos pines, ya que pueden tener niveles intermedios que el analizador los interprete como 0 y el z80 como 1 o viceversa. Para el reloj necesitarías un osiloscopio para ver los niveles reales.

/reset, /wait y /busrq tienen que estar a nivel alto, 5 voltios, porque van conectadas a +5 por resistencias, y en el caso de /reset hay un condensador a masa para hacer el reset automático al enchufar, si en el pin /reset hay algo raro, revisa este condensador.


fenedan escribió:Si la CPU estuviera muerta no reaccionaría desde el segundo 0, eso deduzco por lógica.


Pueden hacer cosas muy raras :roll: . Supongo que no la tendrás en zócalo, porque si lo tiene sería lo siguiente a probar.

Es bastante corriente que dejen de funcionar algunos chips "tocados" un tiempo después de arrancar, cuando se calientan. Algo se dilata y deja de hacer contacto donde debía ...
jzx
Freddy Hardest
 
Mensajes: 989
Registrado: Lun Feb 08, 2010 9:19 pm

Re: ULA sin señal de reloj

Notapor fenedan el Lun Jun 18, 2018 7:29 pm

Gracias jzx. Tomo nota de tus consejos, así que de momento no haré el recap si no es necesario. Pensaba que hacerlo podría ayudar a eliminar incertidumbres.
Miraré específicamente las señales que me propones y ya te cuento.

Saludos!!!
fenedan
rst 0
 
Mensajes: 7
Registrado: Sab May 05, 2018 3:36 pm

Previo

Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 3 invitados

cron