Ayuda: Spectrum +2 suena pero no carga

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Mie Feb 08, 2017 6:53 pm

Hola a todos!

Recientemente ha caído en mis manos un Spectrum +2 (modelo negro). La placa es una Issue 1, y aparentemente todo va perfectamente, salvo el momento de cargar los juegos.

Os detallo lo que ocurre para ver si podéis ayudarme a solucionarlo:

-Le doy a la opción "cargador", pulso el PLAY y el sonido de la carga empieza a sonar por los altavoces de la tele, pero lo único que hace el ordenador es alternar el rojo y el cyan, por lo que parece que el Spectrum se está dando cuenta de que algo está ocurriendo, no?

-El error no es del Azimut ni de la electrónica del cassette, puesto que he desmontado el módulo completo, lo he conectado a otra placa de Spectrum +2 y los juegos han cargado a la primera, así que descartamos el cassette.

-He conectado un módulo de cassete que funciona a la placa Issue 1, y todo sigue igual, por lo que parece ser que el fallo está en la placa issue 1, pero ¿donde? Hay que tener en cuenta que el sonido de la carga llega a los altavoces de la tele... y ahí me he quedado ¿puede tratarse de algún problema en el chip de sonido AY-3-8912?

La verdad es que paerece todo muy raro, y me siento un poco perdido... necesito de vuestra ayuda, por favor!!

Gracias
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor carmeloco el Mie Feb 08, 2017 9:08 pm

Puede ser algo relacionado con el transistor TR4. Lo suyo, sería probar con el mismo cassette, en la placa buena y en la placa mala, midiendo en ambas la señal de colector con un osciloscopio.
¿Quieres un ZX-Uno? puedes comprarlo en:
viewtopic.php?f=12&t=4991
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 404
Registrado: Vie Mar 21, 2008 9:24 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor jzx el Mie Feb 08, 2017 9:26 pm

Si ya has descartado el cassette, busca el esquema y comprueba los componentes que hay entre el conector del cassette y los pines ear y mic de la ula, que indirectamente están conectados entre sí.
El que se oiga por la tele no es muy importante, lo más importante es que el borde cambie de color, si es que lo hace en relación al sonido, ya que quiere decir que la ula "oye" algo, y eso es bueno, posiblemente alguno de esos componentes esté mal y la señal le llegue a la ula débil o distorsionada.
Mira que no haya cosas raras (oxido, algún terminal doblado ...) y si los condensadores no los puedes comprobar tendrás que cambiarlos.
El ay no creo que sea, a no ser que saque algún tipo de sonido que se mezcle con el del cassette.
Indirectamente podría llegar el audio al ear de la ula, pero muy débil y no he oido nunca que dé problemas, y podría pasar simplemente intentando cargar un programa después de que algún otro programa hubiera dejado el ay-3 "en marcha".
jzx
Freddy Hardest
 
Mensajes: 926
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Mie Feb 08, 2017 10:31 pm

Gracias por vuestos consejos!

Otra prueba que he hecho ha sido un SAVE con la placa rota y el cassete en cuestión, y lo hace prefectamente, sin ningún tipo de ruido ni nada extraño.

Espero que esto sea lo que termine de aclarar lo que le pasa a la placa!! ;)

Saludos
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor jzx el Jue Feb 09, 2017 3:58 pm

La ula del 128 tiene un pin de entrada y otro de salida, son más independientes que en el 48k. Repasa los componentes que van el "ear" de la ula.
jzx
Freddy Hardest
 
Mensajes: 926
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Jue Feb 09, 2017 10:59 pm

jzx escribió:La ula del 128 tiene un pin de entrada y otro de salida, son más independientes que en el 48k. Repasa los componentes que van el "ear" de la ula.


Hola de nuevo,

siguiendo este esquema,
http://zxnet.co.uk/spectrum/schematics/Z70833ISSUE1.pdf

los candidatos a ser cambiados en un principio son:
-C200
-TR201
-C202

Aparte de verificar que los diodos D200, D201 y D202 estén correctos.

¿Algún otro candidato que se me haya pasado?

Saludos!!
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor jzx el Vie Feb 10, 2017 5:52 pm

El c202 seguramente no importe mucho, es para llevar el sonido al modulador y lleva una resistencia en serie. El c200 tiene más probabilidades porque es electrolítico. Revisa también soldaduras en la zona, por si acaso.
jzx
Freddy Hardest
 
Mensajes: 926
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Mar Feb 14, 2017 7:00 pm

Hola a todos,

Ya he cambiado el transistor y el condesador electrolítico de 100nF... y todo sigue igual, el borde de la pantalla alterna entre rojo y cyan, pero nos carga los juegos. :| :|

Ahora si que me encuentro bastante perdido, alguien tiene alguna otra idea?

Saludos
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor jzx el Mar Feb 14, 2017 8:18 pm

El electrolítico, c200, es de 1 µF ¿no?. :roll:

Mira las resistencias de base y colector del transistor, las resistencias no suelen fallar, pero ... :?

Puedes medirlas con un polímetro, si no las sacas de la placa seguramente no te darán el valor real, pero puedes más o menos ver algo. Si quieres medirlas bien tienes que desconectar al menos un terminal.

Revisa todas las soldaduras, incluso la del pin de la ula, a ver si hay algo raro, mala soldadura, algún "cuerpo extraño".
jzx
Freddy Hardest
 
Mensajes: 926
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Vie Feb 24, 2017 9:25 pm

Hola de nuevo a todos,

He estado repasando algunas soldaduras relacionadas con la parte EAR de la ULA, incluso he resoldado el pin 2 de la ULA (EAR) para ver si había algún problema.

He cambiado algunos condensadores más, he revisado algunas de las resistencias y comparado los valores con una placa que funciona y no he detectado nada anómalo.

Nada... sigue igual. El ordenador está sordo: Al pulsar el play y comenzar los tonos de carga, hace como que va a cargar (incluso parece que van a aparecer las rayas rojas y azules), y se queda ahí.

Una prueba más que he hecho y que me ha llamado la atención es el del TEST del cassete del propio spectrum. La barrita se mueve al meterle una cinta, y los niveles que muestra el test son los normales de una placa funcionando.

A mi desde luego me parece extraño, porque parece que incluso el test detecta que todo está perfecto

La verdad es que empiezo a pensar que no tiene arreglo... ¿¿¿alguna ayuda, por favor???

Saludos!
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor carmeloco el Vie Feb 24, 2017 10:20 pm

Es un poco raro, porque cuando hace cambios de color y que parece que intentan salir rallas en el borde, suele ser por falta de volumen.
¿Quieres un ZX-Uno? puedes comprarlo en:
viewtopic.php?f=12&t=4991
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 404
Registrado: Vie Mar 21, 2008 9:24 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Vie Feb 24, 2017 10:25 pm

carmeloco escribió:Es un poco raro, porque cuando hace cambios de color y que parece que intentan salir rallas en el borde, suele ser por falta de volumen.


Lo he llegado a pensar, por eso hice el test. Según el Spectrum, la señal parece buena.
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor carmeloco el Vie Feb 24, 2017 10:46 pm

Lo siguiente, ya sería medir señales a osciloscopio. ¿En qué zona de españa estás?
¿Quieres un ZX-Uno? puedes comprarlo en:
viewtopic.php?f=12&t=4991
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 404
Registrado: Vie Mar 21, 2008 9:24 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor robocop48 el Mie Mar 01, 2017 10:15 pm

carmeloco escribió:Lo siguiente, ya sería medir señales a osciloscopio. ¿En qué zona de españa estás?


Por la zona de Cádiz.

Saludos
Avatar de Usuario
robocop48
Jack The Nipper
 
Mensajes: 102
Registrado: Mar Sep 18, 2007 1:40 pm

Re: Ayuda: Spectrum +2 suena pero no carga

Notapor carmeloco el Mie Mar 01, 2017 10:59 pm

robocop48 escribió:
carmeloco escribió:Lo siguiente, ya sería medir señales a osciloscopio. ¿En qué zona de españa estás?


Por la zona de Cádiz.

Saludos

Bufff me queda en la otra punta del pais. Lo decia por si estabas cerca, quedar y le echábamos un ojo.
¿Quieres un ZX-Uno? puedes comprarlo en:
viewtopic.php?f=12&t=4991
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 404
Registrado: Vie Mar 21, 2008 9:24 pm

Siguiente

Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 3 invitados