ZX Spectrum+ no arranca: Dudas reparación.

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

ZX Spectrum+ no arranca: Dudas reparación.

Notapor Acesaliv el Jue Dic 08, 2016 6:25 pm

Buenos días,

Hace unos años desenterré mi viejo spectrum+ y arrancaba, pero tenía la membrana rota y no podía accionar el teclado, así que lo volví a enterrar. Hace poco me volvió la nostalgia y desenterré de nuevo mi viejo spectrum+, pero no conseguí sintonizarlo en mi nueva tele. Descubrí este foro, descubrí que se podía hacer el mod de video compuesto y descubrí que había buena gente que vendía membranas de repuesto así que le encargué una a cdvazquez (gracias amigo) y la cambié y le hice el mod de video compuesto.

El problema ahora es que parece que desde la última vez que lo saqué, se le ha estropeado algo más que la membrana y ahora no arranca. Sale el borde blanco y el PAPER continuamente cambiando con rayas horizontales con patrones distintos por columnas, bueno, mejor una imagen y un video:

Imagen
https://www.dropbox.com/s/bkglkj92certiiw/2016-12-08%2014.59.55.jpg?dl=0
https://www.dropbox.com/s/6jph0p374w3wwj7/2016-12-08%2014.00.08.mp4?dl=0

En uno de los hilos alguien aconsejaba un video sobre reparación y me dispuse a seguirlo:
https://www.youtube.com/watch?v=IzgCmldm2H4

Y me encuentro que el primer test ya no me sale bien, pero entre que está en inglés y que no tengo ni idea de electrónica, no estoy seguro de lo que debo hacer. Se supone que hay un regulador a la entrada cuya tercera pata debe tener unos 100kOhms de resistencia al medir entre la pata y la placa que hace de massa. Me refiero a esto:
Imagen
https://www.dropbox.com/s/kbvvlo604un9rf8/repair_1_test_1.jpg?dl=0

Pero a mi me da 0.6kOhms:
Imagen
https://www.dropbox.com/s/0tjty52xvc3cltl/2016-12-08%2014.39.36.jpg?dl=0

En el video me ha parecido entender que si da menos de 100kOhms, es que el regulador está mal. ¿Debo cambiarlo?

¿Voy por el buen camino? ¿Alguna sugerencia o algo que me ilumine el camino?

Muchas gracias.
Acesaliv
rst 0
 
Mensajes: 7
Registrado: Mar Nov 08, 2016 9:25 am

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor carmeloco el Jue Dic 08, 2016 7:23 pm

Bueno, puedes mirar qué tensión tienes entre masa y la pata de la derecha del regulador, al conectarle el alimentador. Deberías tener +5V
¿Quieres un ZX-Uno? puedes comprarlo en:
viewtopic.php?f=12&t=4991
Avatar de Usuario
carmeloco
Sabreman
 
Mensajes: 393
Registrado: Vie Mar 21, 2008 9:24 pm

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor Acesaliv el Vie Dic 09, 2016 7:13 pm

carmeloco escribió:Bueno, puedes mirar qué tensión tienes entre masa y la pata de la derecha del regulador, al conectarle el alimentador. Deberías tener +5V


Hola, lo he comprobado y si, me da 4.97V (supongo que eso vale, ¿o debe ser justo 5?).

¿Entonces el regulador está bien?

He intentado seguir haciendo los tests que indica el video, pero me pierdo. Algunas cosas no me salen como el dice, pero no acabo de entender lo que implica eso.

¿La imagen que produce da alguna pista de cual puede ser el fallo?
¿Que me aconsejais?
¿Lo vuelvo a enterrar y sigo usando los emuladores? Sniff!

Me hacía ilusión volverlo a hacer funcionar... Snif!
Acesaliv
rst 0
 
Mensajes: 7
Registrado: Mar Nov 08, 2016 9:25 am

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor JULIO el Vie Dic 09, 2016 11:50 pm

Hola.
A la salida creo que máximo 5.25V, al 7805 lo damos por inocente en la causa.
Asi que vamos a empezar...

¿Que tipo de mod has hecho? Condensador solo, resistencia+condensador+transistor??

¿Puedes hacer unas fotos de lo que has montado/quitado etc?

Es que....¿has revisado que todo está bien hecho?

Me refiero a restos de estaño pululando por la placa,
trozos de cable o hilos haciendo algún corto raro...
¿has aislado el montaje convenientemente?

Por la imagen...si no cambia el patrón, puede ser fallo de RAM baja por fallo de alimentación en la RAM baja y posible
culpable el ZTX650 y su vecino el ZTX213, si lo que has montado está bien y no has hecho algún corto por algún lado.

Revisa la zona donde se atornilla el disipador de aluminio por si se ha movido y en definitiva, revisa toodo.

¿Zumba la bobina cuando está encendido?...es eso negro que hay al lado del 7805 que tiene cobre enrrollado.
...cuestion de medir los voltajes de las 4116, tiene que haber respecto a masa, 3 voltajes, +5V, -5V y +12v.
Con un polimetro digital los valores cercanos a esto, comooo 4.9V -5.1V y 11.98V
en las 4116 el pin 16 es MASA, el 1 debe tener -5V, el 8 12v y el 9 5v

los integrados tienen una muesca, poniendo la muesca "arriba", 1-u-16 el pin 1 a la izquierda de la muesca y el 16 a la derecha.

y antes de seguir te pido que alguien conocido te pueda ayudar, porque si hay fallo en RAM baja mejor a
alguien con experiencia porque te puedes cargar la placa del toodo.

saludos
Julio
Avatar de Usuario
JULIO
Freddy Hardest
 
Mensajes: 540
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor Acesaliv el Sab Dic 10, 2016 2:21 pm

Hola Julio,

Muchas gracias.

Te comento: El problema es previo a hacerle el mod, ya que con un video VHS viejo pude más o menos sintonizar, pero se veía tan mal que apenas distinguía si estaba sintonizado o no, por eso hice el mod, para ver bien que salía realmente en la pantalla i ahora que lo veo con el Video compuesto, creo que es lo mismo que se intuía con el sintonizador.

El patrón no es fijo, cambia constantemente, de hecho hasta que no le hice la foto no vi que había un patrón de lineas. En el video se aprecia mejor el efecto:

https://www.dropbox.com/s/6jph0p374w3ww ... 8.mp4?dl=0

El mod que he hecho es el del transistor, condensador y resistencia. Compré el pack en retrocables y lo he montado sin anular la salida RF.

En la foto no se aprecia, porque he hecho un poco una chapuza, pero he repasado el circuito y creo que está bien:

Imagen
https://www.dropbox.com/s/do5dd1bs335chxm/2016-12-10%2010.33.06.jpg?dl=0

El condensador se conecta a un RCA aéreo que saco con un cable hacia el exterior. La malla del RCA junto a la resistencia que viene del positivo del condensador hacen contacto con masa en el exterior de la caja del modulador.

La bobina no oigo que haga ningún ruido y respecto a los voltajes en los 4116, el único que me da bien es el pin 9, los otros dos no:

- pin 1: Esperado -5V, me da 0.464V
- pin 8: Esperado 12V, me da 1.48V
- pin 9: Esperado 5V, me da 4.93V

Tenía la esperanza que como mucho tuviera que cambiar algún condensador, pero si es cosa de chips, ya casi que me retiro :cry:
Acesaliv
rst 0
 
Mensajes: 7
Registrado: Mar Nov 08, 2016 9:25 am

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor JULIO el Sab Dic 10, 2016 4:18 pm

Hola.
Bien, a la vista del mod que has hecho, ¿Cómo es que mantienes la salida de RF?
No se puede hacer eso sin un conmutador, abriendo el modulador y ....déjalo, no abras el modulador.
te recomiendo quitar todo lo que has puesto, no hay sintonia porque no debe haber 12v alimentando
el LM1887.

En la manera que lo has montado a la izquierda, si la caja no es un plus y es un gomas
luego todo eso no cabe dentro y se tocarian los extremos, provocando un corto.

Con las medidas de los voltios parece que tienes una averia típica y común que es fallo de ZTX650 y a veces, pocas,
con cambiar el transistor resuelves el problema, lo que ocurre es que suele fallar porque una o mas
de las memorias bajas se han quedado en corto y si cambias solo el transistor vuelve a petar.
Y ojo con el transistor que te den por el ZTX650, porque los habituales BCxxx van justitos para hacer
la mision encomendada y encima las patillas de los transistores de reemplazo no coinciden con él.

Lo siguiente sería desoldar el ZTX650 y probar con continuidad en el polimetro si hay un corto,
si lo hay hay que ir al rail de alimentación de -5v, aislar las memorias bajas e ir una por una
cortando y midiendo sin desoldar nada, para saber cual queda en corto.

Con un interface de diagnóstico y alguna ayudita mas, todo esto se hace enseguida y
queda fuera de tus posibilidades.

Te recomiendo encarecidamente que pidas ayuda a alguien con conocimientos que te lo puede reparar
sin problemas.
Visita la pagina de hardware.speecy.org que te va a ser de gran ayuda.

El equipo es reparable con toda probabilidad.

saludos
Julio.
Avatar de Usuario
JULIO
Freddy Hardest
 
Mensajes: 540
Registrado: Mar May 08, 2007 10:30 am
Ubicación: Castilla La Mancha.

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor Acesaliv el Sab Dic 10, 2016 5:04 pm

Muchas gracias Julio,

La verdad es que pensaba que esto sería más fácil, pero creo que con el poco tiempo que tengo no me queda margen para dedicarle al spectrum, aparte de que los términos empleados ya empiezan a asustarme un poco, je, je.

De momento creo que voy a pausar el proyecto de reparación, pero gracias por las esperanzas, a ver si más adelante me puedo dedicar más al cacharrito y sigo los pasos que indicas.

Muchas gracias.

Otra cosa, ya por curiosidad: ¿No se puede sacar el video compuesto sin mantener la RF? Me pareció entender del articulo de la wiki de speccy.org https://wiki.speccy.org/hardware/salida_videocompuesto_48k que ellos obtaban por hacer eso, y colocar en la caja del teclado dk'tronics una segunda salida RCA.

Muchas gracias por mantener vivo este foro, aún alucino que 30 años después se siga hablando de este fabuloso trasto tan activamente!!!
Acesaliv
rst 0
 
Mensajes: 7
Registrado: Mar Nov 08, 2016 9:25 am

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor Kyp el Sab Dic 10, 2016 6:41 pm

Como dice Julio, por los síntomas parece que algún chip de memoria se ha roto y eso suele provocar que falle el circuito que genera las tensiones de -5 y +12. Es una de las averías más comunes.

Cada dos o tres meses hacemos una reunión de cacharreo en Parla, donde se organiza el Parlabytes. Si te pilla bien pásate con el Spectrum y le echamos un vistazo. La próxima será a finales de febrero si todo va bien.

Poniendo un conector a parte si se puede sacar vídeo compuesto manteniendo RF. Lo que pasa es que lo habitual es aprovechar el conector de RF para no modificar la caja, pero bueno, eso va en gustos. Yo tengo uno con un conector extra 'colgando' y otro que usa el del RF :mrgreen:
Avatar de Usuario
Kyp
Manic Miner
 
Mensajes: 207
Registrado: Lun Dic 16, 2013 7:16 pm

Re: ZX Spectrum+ no arranca: Dudas reparación.

Notapor Acesaliv el Dom Dic 11, 2016 1:40 am

Muchas gracias Kyp por el ofrecimiento, pero Parla me pilla un poco lejos.

Tengo un cuñado que tiene un primo que se dedica a cosas de electrónica, a ver si algun dia le llevo el spectrum y con lo que me habeis dicho, a ver si puede hacer algo.

Ah, en la foto no se ve bien, pero el mod lo hice con un segundo rca que salia con un cable aparte.

En serio, muchas gracias a todos por vuestros consejos.
Acesaliv
rst 0
 
Mensajes: 7
Registrado: Mar Nov 08, 2016 9:25 am


Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 1 invitado