REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Vie Oct 21, 2016 7:30 pm

Hola amigos:
Rescatando un viejo zx spectrum del baul issue 6A de hace muchos años, y se usó un alimentador de otro aparato, claro con polaridad inversa que no me percaté, pues ya sabeis. Soy aficionado y tengo intencion de revivirlo pues tengo mucha nostalgia de aquellos tiempos, pero necesito de vuestra ayuda. Ahora ya tengo el alimentador original y bueno cuento lo que he hecho hasta ahora previo leyendo antes mucho en los foros, pues he seguido muchas pautas parecidas pero me he atascado y no se por donde seguir.

1-He cambiado 7805 y el TR4 le he puesto un BC639, que no coinciden en base y colector, lo cual he cambiado al conectarlo a la placa, pues no he encontrado en las tiendas ningun ZTX650, y al final compre este, aunque he pedido un ZTX651 a CHINA aun esperandole. Tambien he puesto para salida AV, poniendo un condensador de 47uf 25v en la salida. El spectrum no da señal de AV, no se oye ni un ruido de nada, el coil tampoco se oye, se calienta disipador del 7805 un poco.

Las tensiones que he medido con multimetro son:

7805 ---- 10,65 VOLTIOS patilla izq. 5 VOLTIOS patilla dcha.
COIL...... LADO EXTERIOR: 10,71 LADO INTERIOR: 5
TR4 (BC639) ..... 10,73 ---- 5 ------ 0
TR5 ............... 5 ----- 0 ----- 5
TR7................ 10,7 ----- 0 ------ 0
D15......ANODO: 2,5 CATODO: 2,5
D17......ANODO: 0 CATODO: 2,5
IC6....... PATILLA 1: 2,9mV
IC6....... PATILLA 8: 5,07 V
IC6....... PATILLA 9: 5,06 V
C44....... (+) 2,53 V
C45....... (+) 2,58 V
C80....... (+) 10,7 V (-) 2,57 V
C46....... (+) 10,7 V
C74....... (+) 5 V (-) 4,3 V
C79........ 0 en ambos polos
En los puntos que pongo 0 es que marca muy poco, en mV.
D15 y D17 desmontados de placa y medidos con polimetro en diodos correcto.

Agradeceria cualquier ayuda aunque sea pequeña, que me de una luz por donde seguir.
Atte,
Luis Castro desde España.







:|
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Vie Oct 21, 2016 8:48 pm

Mira a ver si alguna de las memoria 4116 se calienta mucho, a veces se cortocircuitan internamente. Si pasa eso, se habrá fundido también Tr4.

No hay ni 12 ni -5 V, por lo que parece que tr4 no funciona, podría ser que lo hayas montado mal?. Comprueba también tr5, por si acaso.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Sab Oct 22, 2016 12:29 am

HOla:
Sigue sin tener imagen, he cambiado de posicion las patillas del TR4 como me dijistes y tenias razon ahora si me da en las patillas de IC6, los voltajes de 12,25 , 5,07 y -5,15, ninguna memoria se calienta, pero no suena nada el spectrum ni tiene señal de imagen, parece muerto. He comprobado tension en R79 y CREO QUE NO SON CORRECTOS pue me da por un lado -5,15v y por el otro -13,51v. Por donde estaria la falla? Gracias de nuevo por la ayuda.

Atte. Luis Castro desde España
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Lun Oct 24, 2016 2:10 pm

No me había fijado la otra vez en que no se veía nada :oops: .

Aunque el convertidor de tensión no funcione y las 4116 estén averiadas, debería dar imagen. No deberías haber tocado el circuito de video hasta ver si funcionaba o no, a lo mejor no se ve nada porque la salida de av está mal hecha. Pulsando una tecla contínuamente deberían de oirse los clics del teclado, prueba con unos cascos en el conector EAR, por si es que el altavoz está mal.

¿se calienta la ula?

Si tienes otro a mano, puedes cambiar cristal de 14 MHz, a veces se avería. Si no podría ser la ula, si tienes otra y está en zócalo podrías probar. Pero si fuera esto, en principio no tandría que ver con la inversión de polaridad, ¿funcionaba antes?.

No he mirado lo de la R79, pero de las tensiones que das en el primer post, unas cuantas son de puntos donde hay tensión alterna, del oscilador, con una frecuencia bastante alta, y un polímetro normal no puede con una señal de estas características, y puede dar indicaciones extrañas.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Lun Oct 24, 2016 7:04 pm

hola:
El spectrum funcionaba antes bien, se averió al cambiar la polaridad; he sustituído solamente el 7805 y el tr4 le he puesto BC639.
No se oye nada ni ruido de teclas, ni zumbidos ni nada, sin imagen. La tension en las memorias IC6 da bien. La ULA no se calienta, aunque le dejo poco rato encendido por si se averia mas. He hecho mediciones en la ULA , PIN 17 ULA: 2,48 V , PIN 15 da mV, PIN 16 da mV y creo que no son correctas. Gracias de nuevo.

Atte.
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Lun Oct 24, 2016 7:35 pm

Las tensiones de la ula, si puedes mirarlas con un osciloscopio, míralas, pero con un polímetro no vale, no puede medir esas cosas.

La ula se calienta bastante, sobre todo las 5C. Mira si le llega corriente, puedes medir la tensión en los dos extremos de la resistencia gorda que hay cerca de la ula, en un lado tienes que tener 5V y en el otro unos 3,5, respecto a masa. Aunque a no ser que se haya cortado alguna pista, si en la salida del 7805 hay 5 V tiene que haberlos en la ula.
Si la ula está bien y tiene señal de reloj, es bastante poco probable que no dé video. Por eso te decía lo del cuarzo, a veces se rompen internamente por un golpe, o dejan de funcionar porque sí.

Creo que lo normal en estos casos es que el 7805 se cortocircuite a masa, pero si ha dejado pasar la tensión negativa ... malo. :?
Si lo tienes por ahí puedes mirar con el polímetro a ver si está cortocircuitado y entre qué patas.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Lun Oct 24, 2016 9:51 pm

Hola:
Gracias de nuevo por tu ayuda. Por ahora, solo dispongo de un multimetro digital. He medido la resistencia gorda cerca de la ULA mide por ambos lados 5 V. En la salida del 7805 tambien he medido y si hay 5 V. El 7805 que cambié lo he testeado y no está en corto. El cristal de cuarzo te refieres a dos componentes que hay al lado de la ULA grises y rectangulares, que pone KDS 14.000 en uno y en el otro 4.433619, ¿se pueden testear a ver si estan bien? De todas formas mirare a ver si lo puedo conseguir. Por otro lado te preguntaria, podria ser que el transistor que he puesto en el TR4 , el BC639 pudiera ser no compatible del todo y me de estos problemas?
Atte.
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Mar Oct 25, 2016 5:10 pm

La ula tiene dos entradas de alimentación, una a 5 V para los circuitos de I/O y otra a unos 3.7, que se regula interiormente para el core. Esta tensión se saca de los 5 V a través de la resistencia "gorda", en ella se produce una caida por el consumo. Si tienes 5 V en los dos lados, y nada de caida es que no hay consumo ... ¿se calienta la ula como debe?. Porque parece que está muerta.
Mira la tensión en el pin 14 (tiene que ser 5 V) y en el 13 (alrededor de 3,5-3,7).

luis escribió: El cristal de cuarzo te refieres a dos componentes que hay al lado de la ULA grises y rectangulares, que pone KDS 14.000 en uno y en el otro 4.433619, ¿se pueden testear a ver si estan bien?


Sí, el que importa es el de 14. El de 4.43 es para el color, si está mal se ve en blanco y negro. No se pueden probar fácilmente, hay aparatos especiales para probarlos, pero lo normal es usar el osciloscopio.

luis escribió: Por otro lado te preguntaria, podria ser que el transistor que he puesto en el TR4 , el BC639 pudiera ser no compatible del todo y me de estos problemas?


Aunque el transistor esté mal, la ula tiene que dar video, saldría sin color porque el lm1889 también se alimenta del tr4, y con basura en la pantalla al no funcionar la memoria baja, ya que el z80 no podría hacer el cls, poner el mensaje de inicio etc. Pero algo saldría. Mira lo de las tensiones en los pines 13 y 14 y si la ula se calienta.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Mar Oct 25, 2016 8:05 pm

Hola:
He medido las tensiones en ULA pin 13 y pin 14 ambos 5,06 V.
Temperaturas: con temperatura ambiental 20ª, he medido con polimetro despùes de 10 minutos y me da:
ULA 22º
7806 30º
coil 29º
ROM 31º
Z80 30º
ZX8401 25º
LM1889 27º

No me digas que puede ser la ULA, Si es la ULA vaya decepciÓn. Está muerto para siempre o se puede conseguir la ULA??
No obstante me mosquea un poco que no haga ninguna vibracion el transformador COil, antes de pasarle esto y cuando le puse el alimentador con polaridad invertida me hacia ruido. Pienso que deberia hacer algo de ruido aunque esté cascada la ULA.
Atte.
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Mie Oct 26, 2016 6:44 pm

luis escribió:No me digas que puede ser la ULA,


Pues es lo que estoy pensando. :?

Normalmente la ula se calienta más, calculo por lo menos 45-50 grados, porque al tacto es bastante molesto. Usa tecnología bipolar, por lo que creo que se calentará parecido aunque no tenga reloj, y de todas formas, parece que no hay consumo en la alimentación del core, porque no hay caida en la resistencia de 15 Ohm (puedes medir la tensión de lado a lado, pero normalmente también se calienta algo). Sólo se me ocurre que miras si está bien asentada en el zócalo. Podrías comprobar que la masa llegue al pin correspondirente, pero a no ser que se haya roto alguna pista ...
Yo probaría la ula en otro spectrum, a ver.

La ula es un chip hecho específicamente para Sinclair, sólo lo tenían ellos. Venden en varios sitios, aunque no he comprado y no te puedo recomendar, pero alguien del foro igual te puede recomendar. En todo caso, son ulas de 30 años, nuevas que fabricaron para reparaciones o sacadas de spectrums rotos, no hay ulas nuevas.

¿has mirado lo de que si estaba cortocircuitado el 7805 viejo?. Si se ha cortocircuitado entre entrada y salida pero no a masa, ha podido meter los 9 voltios al revés a todo el circuito, y entonces habrá más bajas. :|

Intenta probar la ula en otro spectrum, y mira lo del regulador, porque no sea que cambies la ula y luego tengas que cambiar lo demás. ¿estuvo mucho tiempo con la polaridad al revés?

luis escribió: Pienso que deberia hacer algo de ruido aunque esté cascada la ULA.


El ruido de la bobina depende de los accesos de la ula y de la cpu a la memoria baja, ya que entonces aumenta mucho el consumo de la memoria. A veces se nota incluso que según lo que haga el programa cambia algo el sonido, pero no sé si se nota mucho cuando la ula no va (no me he fijado, no me acuerdo). También puede que se oiga menos porque el transistor no es el mismo. Si hay tensiones de 12 y -5, la bobian está funcionando, pero aunque la bobina no funcione, tienes que tener video.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor luis el Mie Oct 26, 2016 7:50 pm

Hola:
Gracias por tu ayuda desinteresada. El 7805 viejo lo he testeado y no me da cortocircuito. La ULA esta bien asentada y hacen contactos todos sus pin con la base. La Masa esta bien. De todas formas ire probando lo que me dices e ire investigando lo de las ULAS, ya te contaré de todas formas.
Atte.
luis
rst 0
 
Mensajes: 6
Registrado: Sab Oct 15, 2016 10:59 pm

Re: REPARANDO SPECTRUM ISSUE 6A POR CAMBIO DE POLARIDAD

Notapor jzx el Jue Oct 27, 2016 7:04 pm

Intenta lo de probar la ula, por si acaso. Si está mal, a lo mejor alguien del foro te puede recomendar algún sitio donde comprarla.
jzx
Freddy Hardest
 
Mensajes: 910
Registrado: Lun Feb 08, 2010 9:19 pm


Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 3 invitados

cron