Ayuda reparación Inves Spectrum+ [RESUELTO]

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Re: Ayuda reparación Inves Spectrum+

Notapor jzx el Jue Sep 15, 2016 6:40 pm

cdvazquez escribió:Cambié el de 17.7345 por uno de 17.7344 que tenía por aquí y ya está andando perfectamente (entiendo que no habrá problema por esa diferencia).


Acabo de ver este detalle, la frecuencia de la subportadora es muy específica y muchas veces aunque se use el cristal correcto hay un condensador ajustable para afinar, o sea que no descartaría que sea eso. Y seguramente las teles modernas sean menos tolerantes ¿has probado con más de una?.

Si haces la prueba de la tele bn, tendrías que ver los "puntitos".

(me parece raro que existan cristales de 17.7345 y de 17.7344 :?: ).


Edito: veo que has empezado a seguir la pista a la señal de colorclk, tendrás que mirar lo que hay en el transistor y hacer un esquemilla a ver. Es raro que se haya roto algo por ahí, pero a lo mejor algún condensador, alguna soldadura.

Si tienes dos inves, podrías intercambiar los cristales, a ver si lo de la diferencia de frecuencia es importante.
jzx
Freddy Hardest
 
Mensajes: 900
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda reparación Inves Spectrum+

Notapor cdvazquez el Vie Sep 16, 2016 12:45 am

Gracias a los dos por la ayuda...

Aunque intentaré intercambiarlos, yo creo que lo del cristal es cuestión de redondeos. El estropeado decía 17.7345, el que funciona en el otro Inves pone 17.73447 y el que usé para substituir el malo indica 17.7344.

Estuve siguiendo la pista (literal) y ya encontré el recorrido:

En OSC IN (17) está C42, cuyo otro extremo va a masa. Entre OSC IN (17) y OSC OUT (18) del MC1377P hay un condensador C38, luego C9 y este conectado a la pata 3 de Q6 (BC212B).

La pata 2 de Q6 va a la bobina L3 y de ahí, un par de condensadores más y una resistencia y ya estamos en la salida de reloj de color del TAHC10.

La pata 1 de Q6 va a unas resistencias y algún condensador más.

Siento el ladrillo... escribiéndolo me doy cuenta que sin pintarlo es un follón... lo que sí me sorprende es que haya tantos componentes por el medio para enviar el reloj del TAHC10 hacia el MC1377P.

Creo que intentaré también lo de la pata 1 del MC1377P que me indicas y cambar Q6, a ver si va a ser eso.

... y si no, ya me rindo y que descanse (el color) en paz.

Saludos.
Avatar de Usuario
cdvazquez
Jack The Nipper
 
Mensajes: 106
Registrado: Lun Nov 04, 2013 10:26 am

Re: Ayuda reparación Inves Spectrum+

Notapor jzx el Vie Sep 16, 2016 5:08 pm

cdvazquez escribió:Aunque intentaré intercambiarlos, yo creo que lo del cristal es cuestión de redondeos. El estropeado decía 17.7345, el que funciona en el otro Inves pone 17.73447 y el que usé para substituir el malo indica 17.7344.


Lo he mirado y oficialmente es 4.43361875 x 4 = 17.734475.

Según el datasheet del mc1377, hay que poner un condensador variable para ajustar la frecuencia en cada chip / placa. Según dice, la mayoría de teles y monitores (de la época) admiten una variación de unos 1200 Hz (en los 4.43 Mhz, sería 4800 en los 17.73).

También hay que tener en cuenta que el cristal necesita unos condensadores para funcionar, y hay que poner los que dice el fabricante, aparte de que luego haya que afinarlo. Es posible que el cristal que pusiste necesitara unos condensadores distintos a los que hay en la placa y por eso se sale de la tolerancia que admite la tele, aunque para funcionar la parte digital no tenga importancia.

cdvazquez escribió:En OSC IN (17) está C42, cuyo otro extremo va a masa. Entre OSC IN (17) y OSC OUT (18) del MC1377P hay un condensador C38, luego C9 y este conectado a la pata 3 de Q6 (BC212B).


Puff... tendrías que hacer un dibujillo ... :wink: .

cdvazquez escribió: lo que sí me sorprende es que haya tantos componentes por el medio para enviar el reloj del TAHC10 hacia el MC1377P.


Creo que el problema es que la entrada de la señal no es una entrada digital, sino los pines donde normalmente iría un cristal.
Según el fabricante, hay que meter una señal de 0.5 a 1 V, senoidal. Seguramente cuadrada valdría, pero probablemente senoidal dé mejor resultado (mejor calidad del color). Si hay por medio condensadores y bobinas, seguramente tendrá algún tipo de circuito resonante. Podría haberse roto la bobina, en algunos tipos a veces se rompe el hilo por dentro por algún golpe.


cdvazquez escribió:... y si no, ya me rindo y que descanse (el color) en paz.


Intenta probar lo de la tv con entradas diferencia o bn, si ves la subportadora el problema no es que no llegue la señal al mc, sino que será la tolerancia del cristal o del rc del pin1.

(supongo que no hay osciloscopio :( ).

cdvazquez escribió:y que descanse (el color) en paz.


Bueno, o usas RGB :D :D :D :D .
jzx
Freddy Hardest
 
Mensajes: 900
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda reparación Inves Spectrum+

Notapor cdvazquez el Sab Sep 17, 2016 2:05 am

Voy a ver si me echan una mano con el osciloscopio y, al menos, saber lo que sale de ahí... lo sé usar (aunque no tengo uno en casa) pero en estas cosas concretas no tengo experiencia así que mejor busco pack osciloscopio+"elquesabe".

He intercambiado los cristales y los MC entre ambos Inves y se comportan igual. También cambié el condensador de la pata 1 (101) porque por probar que no quede.

Informaré si hay avance... ya es cabezonería :oops: gracias por la ayuda.
Avatar de Usuario
cdvazquez
Jack The Nipper
 
Mensajes: 106
Registrado: Lun Nov 04, 2013 10:26 am

Re: Ayuda reparación Inves Spectrum+

Notapor jzx el Lun Sep 19, 2016 7:21 pm

Primero de todo, usa la sonda de 10:1, siempre. La de 1:1, mala :D . Si usas la de 1:1, posiblemente cargues demasiado el circuito y lo que midas no valga y te lies más.

Con el osciloscopio primero tendrías que mirar si hay señal en la entrada osc in, debería ser 4.43 MHz, probablemente senoidal (porque supongo que la bobina que decías que había en el camino será un filtro) y de 0,5 a 1 V. Si es un osciloscopio moderno podrás medir la frecuencia, pero si no es de "gama alta" no tendrá suficiente precisión como para decir si hay un problema de tolerancias.

Si hay señal, mira la salida de video compuesto (que se vea 1 línea de tv, 10 us/div) , poniendo el borde de algún color (no blanco ni negro) y tendrás que ver la salva y la portadora en la parte correspondiente al borde. Si la salva está muy cerca del sincronismo de línea o muy lejos o no está, seguramente será cosa de la resistencia/condensador del pin 1. Podría ser del mc también, pero en mi caso acabé poniendo un potenciómetro (no era un inves ...) y ajustar.

Puedes leerte esto mientras: :lol:

www.pl-1.org/getproductfile.axd?product ... MC1377.pdf
jzx
Freddy Hardest
 
Mensajes: 900
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda reparación Inves Spectrum+ [RESUELTO]

Notapor cdvazquez el Mie Sep 28, 2016 11:34 pm

Bueno... pues misterio resuelto.

Cuando estaba hablando con este compañero (es un artista con la electrónica) para quedar y verlo con el osciloscopio... y tras comentarme varias cosas que ya había mirado, me dió una idea que... sí funcionó.

Me comentó que le resultaba sospechoso que se hubiera estropeado el cristal, que mirara el condensador que siempre llevan al lado. Me comentó que si ese condensador estaba mal, varía la oscilación del cristal... y que eso llevaría a que la frecuencia para la portadora de color no fuera la correcta.

Hoy lo acabo de mirar y me encontré un condensador de 220pF (221K)... miro mi Inves, que funciona bien, y tenía uno de 47nF. Le cambio ese condensador por uno de 47nF 50V... ¡Y EL COLOR APARECIÓ!

Lo que más me sorprende es que el condensador de 220pF tenía pinta de estar ahí "de toda la vida". Las soldaduras no tenían ninguna pinta distinta del resto de la placa, daban la sensación de ser las de origen.

[EDITO] Le he enviado un e-mail a un amiguete que tiene también un Inves para saber si ese condensador tiene esa misma medida... y me dice que tiene uno de 22nF y que la imagen se ve azulada. ¿Qué pasa? ¿ponían ese condensador según viniera el viento?... ¿ajustaban uno a uno?.

Muchas gracias a todos por la ayuda... sois unos soletes.

Saludos,

Carlos
Avatar de Usuario
cdvazquez
Jack The Nipper
 
Mensajes: 106
Registrado: Lun Nov 04, 2013 10:26 am

Re: Ayuda reparación Inves Spectrum+ [RESUELTO]

Notapor jzx el Jue Sep 29, 2016 1:42 pm

cdvazquez escribió:uno de 47nF 50V.


Será pF no? :D .

Estos condensadores dependen de las características del cuarzo, el fabricante te dice la capacidad que hay que poner, y hay que considerar las capacidades parásitas y la de la parte electrónica. Supongo que cambiarían de proveedor de los cristales y por eso unos lotes salieron con un valor y otros con otro. Si los fueran a ajustar uno a uno hubieran puesto un ajustable, como en los primereos modelos de Sinclair.

Los cristales no se suelen averiar, pero no aguantan mucho los golpes, yo he encontrado alguno roto (agitandolo se oía el trozo suelto dentro de la lata).
jzx
Freddy Hardest
 
Mensajes: 900
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Ayuda reparación Inves Spectrum+ [RESUELTO]

Notapor cdvazquez el Jue Sep 29, 2016 11:06 pm

Sí... 47pF, es cierto (47 con una línea por debajo), perdón.

Lo que dices tiene sentido... el problema está con los recambios que tengo aquí en su bolsita, que no sé el fabricante ni qué recomendación pueden tener.

En cualquier caso, funciona bien así que no me quejo.

Gracias de nuevo por la ayuda.
Avatar de Usuario
cdvazquez
Jack The Nipper
 
Mensajes: 106
Registrado: Lun Nov 04, 2013 10:26 am

Previo

Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: No hay usuarios registrados visitando el Foro y 1 invitado