Dos ordenadores Spectrum con problemas [ARREGLADO]

Si por algo se caracteriza el Spectrum es por su gran variedad de periféricos (clásicos y modernos)

Moderador: Sir Cilve Sinclair

Dos ordenadores Spectrum con problemas [ARREGLADO]

Notapor NeilParsons el Jue Dic 20, 2012 8:19 pm

Vayamos por partes:

Por un lado, tengo un Spectrum 48k plus comprado hace ya unos cuantos meses de segunda mano, al cual hace poco le tuve que cambiar la membrana por estar defectuosa por otra nueva, adquiriendo ésta a Rich Mellor de RWAP Software. Tras algunos avatares con una primera membrana que me envió la cual no encajaba perfectamente con las sujeciones de plástico por la cara interna de la carcasa y que tuve que devolver a cambio de otra nueva que corrigiera este pequeño defecto de medida, ni con la anterior ni con la nueva que ahora poseo consigo la total operatividad del teclado, quedándose en poco más del 50 %. No funcionan las teclas del 6 al 0 (cero), ni las teclas de función Delete y Graph por sí solas, ni casi toda la fila central (de la A hasta ENTER), ni las teclas de cursor derecha, arriba y abajo. El resto sí funcionan.

He probado a conectar otras membranas de otros Spectrum 48k que tengo (y que me funcionan sin ningún tipo de problemas), con sus teclados, y pasa lo mismo, con lo que el problema puede estar justamente en el interior del 48k plus.

Pero lo realmente gracioso es que pulsando Delete con alguna de las teclas del 6 al 9 me imprimen en pantalla los tokens de las teclas de la Z a la V o sus letras, pero al revés. Es decir, si pulso Delete + 6, se imprime en pantalla la letra V (en mayúscula) o el token de esa tecla (CLS), si es Delete + 7, imprime la C o CONTINUE, Delete + 8, la X o CLEAR y Delete + 9, Z o COPY. Tela marinera... :?

Ya he escrito a Rich Mellor comunicándole el problema y espero que él me diga si es cosa del ordenador, como espero que alguien del foro me lo pueda aclarar. Estoy por enviar el ordenador a quien desee cacharrear con él y comprobar qué le pasa realmente, incluso probar en él otra clase de membrana de teclado.

-----

Y vamos con el segundo tema, también con otro de mis Spectrum, en este caso un clon portugués que compré igualmente de segunda mano, y creo que hasta hablé de él en otro subforo de speccy.org que hasta ahora no había probado del todo:

Imagen

Las fotos están en Picasa para que se puedan ver a mayor tamaño todo lo que tiene de sí el mismo. Tiene varias cosas que me han dejado "mosca": por un lado, le han soldado un cable con una toma RCA a un interfaz de joystick con su conexión preparada a tal efecto (de todas formas, con o sin esa conexión extra, el ordenador se ve igual). A pesar de estar correctamente sintonizado al televisor, la imagen es deficiente y el color se muestra con problemas: en dos de las fotos que se ve la pantalla a color, el borde lleva activado el color amarillo (BORDER 6). Otro problema es que cuando pasa un corto espacio de tiempo llegan a aparecer en la pantalla en su margen izquierda una serie de cuadros y pixels algo sospechosos, sin haber hecho prácticamente nada, salvo comprobar el teclado y ejecutar unas pocas instrucciones, entre ellas la de dar un color al borde.

En el interior, hay un cable que ni siquiera está debidamente soldado en uno de sus extremos al transistor MPS 2369, según da a entender las mismas imágenes.

Las patillas de la membrana, también comprada a RWAP Software, o son muy finas en comparación con otras, o tienden a salirse con facilidad de los conectores, o bien que éstos tengan más holgura en su interior para acoplarlas. Para que el teclado funcione del todo, tuve que meter dos piezas pequeñas de papel en los conectores para que las patillas estén más firmemente conectadas a la placa del ordenador. Sin éllas, no responden todas las teclas, pero al incluirlas, sí.

En fin, tiene un poco de todo, pero espero que sea fácil de reparar e incluso me gustaría prescindir de ese cable RCA, si es posible. Al menos, quiero su arreglo y por eso busco a alguien sin demasiado trabajo en estos dias para que les eche un vistazo. No me importa esperar lo indecible.
Ultima edición por NeilParsons el Mar May 28, 2013 1:06 am, editado 2 veces en total
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor jzx el Jue Dic 20, 2012 8:56 pm

En el portugués:
Tendrías que miralo, pero el transistor ese puede que sea el que normalmente se montaba sobre el z80, mira con un polímetro a ver si coinciden las conexiones con el esquema del issue two.

Lo de la membrana, es posible que la del original no fuera exáctamente igual que la de sinclair y tuviera el plastiquillo del final de las cintas más gordo, no tienes la vieja para comparar? (aunque viendo las fotos parece que la membrana actual no tiene nada en el extremo a parte de la propia cinta)

Luego tienes dos problemas, uno analógico por la mala señal de video y otro digital, por lo de que aparecen pixels y cosas raras en la pantalla. Mira las tensiones de la memoria baja, los 12 v también alimentan al chip que hace la modulación de color, a ver si la tensión es la correcta y comprueba los condensadores de filtro de 12 y -5 V, si estas tensiones no fueran correctas podrían afectar a las dos cosas a la vez, aunque también pueden ser dos averías independientes.

Yo quitaría el cable de video, por si afecta. Luego si acaso pones una salida de video, y revisaría los potenciómetros también, puedes marcar la posición y girarlos un para de veces de lado a lado, a ver si mejora la cosa.

Por curiosidad: han pintado de verde las soldaduras de los condensadores ??
jzx
Freddy Hardest
 
Mensajes: 992
Registrado: Lun Feb 08, 2010 9:19 pm

Re: Dos ordenadores Spectrum con problemas

Notapor NeilParsons el Jue Dic 20, 2012 9:54 pm

No tengo conocimientos en hardware, por eso hago esta consulta a los especialistas en el tema. Aparte de McLeod-Ideafix que es un hacha en estas cuestiones, me preguntaba quién más podría ayudarme con estos ordenadores.
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor flopping el Jue Dic 20, 2012 10:01 pm

Hola, yo si quieres les puedo echar un vistazo, si no tienes mucha prisa y dependiendo de lo que tengan, puede que los tenga reparados antes de año nuevo o después, primero debería de verlos para confirmártelo.

Te explico lo poco que he visto, el cable que esta suelto del transistor debería de ir efectivamente soldado a el, supongo que la patilla que no tiene nada soldado, es la que debería de tener el cable suelto, de todas formas eso no impide que se vea bien, el transistor es para otra cosa.

Mas cosas, el cable rojo que sale del modulador, debe de ser video compuesto, no hay que sintonizar nada, solo conectarlo a la entrada de video del televisor o monitor y deberias de verlo.

Lo de la membrana, es normal, ya que en las cintas originales hay un plástico duro, que esta pegado al lado contrario de los contactos y es precisamente para poder hacer presión, pues las cintas solas no hacen buen contacto, ya que son muy finas, el resto de cosas tendría que revisarlas y ya te diría algo, bueno tu mismo, ya me dices lo que sea, yo soy de Valencia, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, debido a la esquizofrenia paranoide que tengo.
(C) 1982-2016, 34 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente"
Avatar de Usuario
flopping
Nonamed
 
Mensajes: 1093
Registrado: Vie Jul 16, 2010 9:54 am

Re: Dos ordenadores Spectrum con problemas

Notapor NeilParsons el Jue Dic 20, 2012 10:22 pm

Pues me harías un favor muy grande, ya que les he cogido un cariño especial. Te los mandaría por correo certificado si me dices tu dirección en privado y, en cuanto los tuvieses, ya me contarías qué otros síntomas puede tener el "gomas" de Timex/Sinclair.

Si el cable de video compuesto es para conectarlo directamente al televisor (el que lo pueda admitir), entonces la cosa cambia.
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor flopping el Jue Dic 20, 2012 10:30 pm

Como ya te he comentado, no se ven bien las fotos, pero por lo que veo, el cable esta conectado a la entrada del modulador y es para sacar video compuesto directamente, no es la solución mas "elegante" ni de mejor calidad, pero para salir de paso puede valer, evidentemente, se puede quitar y dejarlo como venia de origen o "adecentarlo" un poco y hacer algo mejor.

El timex-sinclair, es una versión de placa issue 2 y como puedes ver tiene 4 ajustes, dos de ellos son para la colorimetría del spectrum, por eso no se ven bien los colores, hay que ajustarlos para que los colores sean correctos, ya que puede que el blanco se vea algo amarillo o azulado y asi con todos los colores, pero vamos que es ajustarlos y ya esta, también el integrado que genera el video, se le pueden colocar unos condensadores que hacen de filtro y que mejoran la imagen bastante.

Como te comento, el resto de cosas habría que verlas, pero no parece que sea un tema complicado en exceso, te mando un privado con mi dirección para el envio y ya te digo mas cosas, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, debido a la esquizofrenia paranoide que tengo.
(C) 1982-2016, 34 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente"
Avatar de Usuario
flopping
Nonamed
 
Mensajes: 1093
Registrado: Vie Jul 16, 2010 9:54 am

Re: Dos ordenadores Spectrum con problemas

Notapor NeilParsons el Mar Dic 25, 2012 2:23 am

El paquete con los ordenadores te lo mandaré el miércoles. Resulta que no me acordaba que el lunes cerraban las oficinas de correos por el tema de las fiestas. Sin problemas.
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor flopping el Mar Dic 25, 2012 11:36 pm

Ok, por mi parte no hay prisa, asi que sin problemas, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, debido a la esquizofrenia paranoide que tengo.
(C) 1982-2016, 34 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente"
Avatar de Usuario
flopping
Nonamed
 
Mensajes: 1093
Registrado: Vie Jul 16, 2010 9:54 am

Re: Dos ordenadores Spectrum con problemas

Notapor NeilParsons el Mie Dic 26, 2012 2:08 pm

Ya ha salido esta mañana de camino a tu casa.
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor NeilParsons el Sab Ene 12, 2013 12:26 am

Flopping, en cuanto tengas un hueco, échale un vistazo a mis ordenadores y en cuanto tengas un diagnóstico, me lo dices.
Avatar de Usuario
NeilParsons
Dizzy
 
Mensajes: 1054
Registrado: Mar Oct 02, 2007 5:13 pm

Re: Dos ordenadores Spectrum con problemas

Notapor flopping el Sab Ene 12, 2013 12:55 pm

Si, así lo haré, ¿te puedes creer que aun no he tenido tiempo de abrir la caja donde me los enviaste?, pero la semana que viene tengo unos huecos y lo mirarme y ya te digo algo, salu2.
No me hago responsable de mis post pues estan escritos bajo la influencia del alcohol y drogas psicotropicas, debido a la esquizofrenia paranoide que tengo.
(C) 1982-2016, 34 años de ZX Spectrum.
http://www.va-de-retro.com/ un foro "diferente"
Avatar de Usuario
flopping
Nonamed
 
Mensajes: 1093
Registrado: Vie Jul 16, 2010 9:54 am

Re: Dos ordenadores Spectrum con problemas

Notapor celestinox el Sab Ene 12, 2013 1:44 pm

Hola a todos los foreros. A ver si alguien puede ayudarme. Yo también tengo un par de spectrum (1 gormas y 1 plus) y el problema es que aparte de la muy mala calidad de imagen en RF que no se como solucionar; mi divide plus no funciona con ellos, (en cambio funciona bien en el +2A, por supuesto con el puente interior cerrado). He estado hablando con la gente de RWAP Software.(por cierto les he comprado una membrana para el gomas, y si es verdad que son muy finas, aunque no he tenido que reforzarlas, me funcionan bien) y me estuvieron comentando que probablemente los Z80 sean clonicos y carezcan de señal M1, pero he visto que son genuinos zilog por lo que lo he descartado, además no he visto derivaciones ni cortos en los PCBs con el polímetro, y hay continuidad desde z80(m1) al bus de expansión. Les comento esto y me comentan que probablemente la frecuencia de oscilación de la bobina no sea correcta. Así que tras repasar hilos de este y otros foros, me ha parecido entender que el circuito se usa para generar +12v, y-5v para las memorias, y que la frecuencia de oscilación para este circuito es de 114Khz. Con el polímero las tensiones en las memorias parecen correctas. Pero la tensión midiendo en alterna sobre terminal LT de C46 (hablo de placas issue4B) y masa me da 0.3v , y si mido en contínua me da 10v; ¿que debería medir?¿12v ac?. segun esquema es la misma señal del bus 23A). Mirando esta señal con un osciloscopio, no soy capaz de medir la frecuencia, por que fluctúa muchísimo, parece mas una señal PWM que un señal estable. El oscilador a base de la bobina y los 2 transistores debe generar una señal estable de 114KHz o es así de inestable?. Por cierto que significan las siglas LT,RT,BK que aparecen en algunos componentes en el esquema?.
Un saludo.
celestinox
Herbert
 
Mensajes: 50
Registrado: Vie Dic 07, 2012 7:55 pm

Re: Dos ordenadores Spectrum con problemas

Notapor mcleod_ideafix el Sab Ene 12, 2013 7:57 pm

celestinox escribió:me estuvieron comentando que probablemente los Z80 sean clonicos y carezcan de señal M1, pero he visto que son genuinos zilog por lo que lo he descartado...

En realidad es al revés, son los Z80 de Zilog los que parece ser que tienen el problema con M1, y los NEC Z80 los que tienen la señal M1 "mejor" (según leí en su día en WOS)

celestinox escribió:además no he visto derivaciones ni cortos en los PCBs con el polímetro, y hay continuidad desde z80(m1) al bus de expansión

El error es interno, dentro del chip.

celestinox escribió:vLes comento esto y me comentan que probablemente la frecuencia de oscilación de la bobina no sea correcta

No veo qué tiene que ver la frecuencia de la bobina del conversor DC-DC con que funcione o no tu DivIDE+, o la señal M1. Si obtienes una tensión de alrededor de -5V donde debe estar, y una tensión de alrededor de 12V en su sitio, y tu Spectrum funciona bien, no me precouparía mucho más.

celestinox escribió:Por cierto que significan las siglas LT,RT,BK que aparecen en algunos componentes en el esquema?.
Un saludo.

Respectivamente: izquierda, derecha, trasera (se refiere a la posición física de los pines en las resistencias del esquemático en la PCB.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Re: Dos ordenadores Spectrum con problemas

Notapor celestinox el Sab Ene 12, 2013 8:45 pm

Gracias mcleod_ideafix por tu pronta respuesta. Pues es cierto, a pesar de tener continuidad hasta el bus, la pata 27 (M1) está muerta, no tiene actividad. Estos de RWAP Software se estan quedando conmigo, o solo hablan por hablar; será que como les he preguntado por las GAL actualizadas, me las quieren encasquetar.
En cambio e comprobado esto mismo del M1 en un inves+ y el divide funciona; viéndose actividad en el osciloscopio. No se por que no funciona este pin en el gomas. ¿salió de fábrica así?¿o es que se estropean?.
Tengo un par de z80s de sendos +2. creo que se podrán intercambiar. La pregunta que me viene; ¿es fácil desoldar el z80 del pcb con un desoldador de pera?. ¿Algún consejo??

Gracias.
celestinox
Herbert
 
Mensajes: 50
Registrado: Vie Dic 07, 2012 7:55 pm

Re: Dos ordenadores Spectrum con problemas

Notapor mcleod_ideafix el Sab Ene 12, 2013 8:52 pm

celestinox escribió:¿salió de fábrica así?¿o es que se estropean?.

Probablemente salió así de fábrica.

celestinox escribió:Tengo un par de z80s de sendos +2. creo que se podrán intercambiar. La pregunta que me viene; ¿es fácil desoldar el z80 del pcb con un desoldador de pera?. ¿Algún consejo??

Fácil o difícil depende de tu pericia. La placa del Spectrum tiene muuucho estaño, por lo que mi consejo es: paciencia, malla de desoldar, flux, y no te pases con el calor, o saltarán las pistas.
Web: ZX Projects | Twitter: @zxprojects
Avatar de Usuario
mcleod_ideafix
Johnny Jones
 
Mensajes: 3984
Registrado: Vie Sep 21, 2007 1:26 am
Ubicación: Jerez de la Frontera

Siguiente

Volver a Hardware

¿Quién está conectado?

Usuarios navegando este Foro: Google [Bot] y 3 invitados